Sou bastante leigo na eletrônica, mas gosto de fazer alguns projetos as vezes, mas desta vez me deparei com um problema. Criei um pequeno circuito para controlar dois mosfet por pwm, esses mosfets controlam leds 12v, bastante leds, chegando a 5A. mas como é para 2 mosfets, trabalham com 2,5A cada um. pois bem, os mosfets que utilizo são dois IRF640, mesmo sendo de 18A e trabalhando com 2,5A, eles esquentam muito, a ponto de queimar. Dei uma pesquisada e vi algumas pessoas falando sobre Bootstrap, outras falando sobre limitar a corrente do Gate com resistor, se algum de vocês poderem tirar essa minha duvida e esclarece-la ficarei grato! 

Ligo os mosfets direto nas portas pwm de um arduino (5V).


-------------(ATUALIZAÇÃO)------------

Hoje fiz algumas medições, aqui estão:

Do pino 9 para o Gate do mosfet1: 4.80V

Do pino 10 para o Gate do mosfet2: 4.80V

Da fonte para ambos os sources: 11.60V

A saída do Drain com PWM no Gate à 255: 10.20V

A saída do Drain com PWM no Gate à 0: 8.20V

Com a variação de PWM de 0 à 255, a variação na voltagem está sendo de 8.20V à 10.20V.

Imagens da montagem:

Exibições: 3414

Responder esta

Respostas a este tópico

Boa tarde IB,

realmente usando estes MOSFETs, com uma corrente de 2.8 A, não deveriam aquecer.

Mas vamos entende um pouco o funcionamento do MOSFET.

O funcionamento do MOSFET parece mais com o funcionamento de uma válvula antiga (aquelas de vidro),

do que com um transistor.

Simplificando: O transistor com corrente de base/emissor controla-se corrente de coletor/emissor.

O MOSFET com tensão de porta (gate), controla-se corrente de dreno/supridouro.

Praticamente não existe corrente de porta, portanto não seria necessário um resistor ligado á porta.

Mas, se seu MOSFET der defeito e entrar em curto a porta com o supridouro, você vai colocar

o port do seu arduino em nível de gnd, e ao entrar em HIGH poderia danificar seu port.

Recomento, para proteger seu arduino, um resistor de pelo menos 1K entre o port e a porta do MOSFET.

Mas isto não é o seu problema de aquecimento.

O aquecimento está ocorrendo porque o MOSFET está sendo usado como limitador de corrente dos seus LEDs.

Todo LED, ao ligar em uma fonte de tensão, precisa de um resistor limitador de corrente.

Sem este resistor, a corrente interna do LED tende a subir sem limitação e queima o LED.

Mas no seu caso como você não usou resistor em serie com os LEDs, este trabalho está sendo exercido pelo 

MOSFET, o que por si provoca o aquecimento do mesmo e a sua destruição por excesso de aquecimento na junção.

Não sei como são estes seus LEDs, mas ou você usa um resistor pra cada LED ou usa um para o conjunto todo.

RV

Tente adicionar uma imagem com o esquema corrigido, mas está dando erro

A imagem está em:  https://imgur.com/a/yvncqAJ

Olá amigo, aqueles leds é apenas para simbolizar o conjunto de leds que uso, estou usando uma barra de led smd, todos os led já vem com resistores. Se quiser dar uma olhadinha: LEDS

Qual valor dos resistores da barra?

Áh, e quantos LEDs tem cada barra?

RV

Cada barra tem 24 tiras, cada tira tem 3 LEDS já com o resistor apropriado.

OK, 24 x 3 = 72 leds 

Não são tantos LEDs assim. 

Aparentemente o Mosfet não deveria esquentar e nem queimar. 

Mande uma foto detalhada da sua montagem. Você pode ter cometido algum engano.

Que fonte esta usando ? - envie as especificações. Mediu a tensão na saída da fonte,  enquanto esta funcionando? 

https://softsolder.com/2012/12/05/arduino-snippets-rgb-led-strip-wi...

Olá amigo, fiz algumas medições e atualizei o post, se puder dar uma olhada eu ficaria feliz. Grato!

Bom dia IB,

bom artigo para ler sobre MOSFET usado como "chave".

RV

https://electronics.stackexchange.com/questions/343220/how-to-desig...

Olá amigo, fiz algumas medições e atualizei o post, se puder dar uma olhada eu ficaria feliz. Grato!

Boa noite, 

Não dá para entender o seu diagrama.

Em quais portas estão conectadas os gates do Mosfets? 

O pino 2 da fonte é o Terra? O pino 1 é o positivo?

Essas tiras de LEDs já tem resistores limitadores de corrente e são alimentadas com 12V

Boa noite amigo.

Um na porta 9, e outro na porta 10.

Sim, o pino 1 é positivo, e o 2 o negativo.

Sim, as tiras já tem os resistores. 12V

Pelos seus comentários está tudo correto. Mas se estivesse correto não estaria esquentando...

Ele deveria estar sempre em um desses 2 estados:

1) Ligado - Quando não tem tensão nenhuma sobre ele e tem a corrente máxima sobre ele. Potencia mínima (P=UxI) Trabalha como se fosse um curto circuito, uma chave fechada. Claro que não é perfeito, mas um transistor desses faz ficar quase totalmente fechada essa chave.

2) Desligado - Com toda tensão sobre ele mas nada de corrente. Potencia minima pq a corrente é zero. Trabalha como chave aberta.

Vc precisa identificar com um multimetro esses estados. Ligue os leds e meça a tensão sobre o transistor, veja se ele está realmente conduzindo perfeitamente. A tensão deve ser super baixa. Desligar e ver se a corrente zerou.

Meu palpite é que a tensão sobre ele vai ser alta, uns 3V, indicando que ele não está conduzindo completamente. Não conduz completamente quando não recebe 5V perfeitos no gate. Não recebe 5V perfeitos por ex quando vc não colocou o pino como saída (pinmode) ou não interligou corretamente os GND, colocou um fio fino ou conector que não suporta a corrente em algum lugar.

Confira se seu pino solta 5V mesmo, se tem o devido pinmode.

Convém por um resistor, ainda que baixo, menos de 1K, no gate. Não para o circuito trabalhar bem, não vai fazer diferença alguma, mas para caso vc ligue errado, o transistor queime, etc, o microcontrolador receba uma sobrecarga menor, com mais chances de sobreviver.

Mande uma foto.

Olá amigo, fiz algumas medições e atualizei o post, se puder dar uma olhada eu ficaria feliz. Grato!

RSS

© 2021   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço