Lilygo T-Display ESP32 S3 - Display não mostra nada

Ola,

Acabei de receber uma unidade do Lilygo T-Display ESP32 S3 que comprei no Aliexpress.

Estou usando o Arduino IDE 2.00, atualizei a biblioteca de acordo com a recomendação do fabricante e de alguns makers no youtube.

Estou tentando rodar um código de um youtuber famoso ( https://www.youtube.com/watch?v=j8THAc1sMww ).

O Arduino IDE compila e faz o upload do código na placa. Não há aviso de erro algum, porém o Display permanece apagado.

Alguém aqui com experiência nessa placa, ou alguma idéia de como resolver?

Exibições: 149

Responder esta

Respostas a este tópico

Bom dia,

Nunca usei este display.Qual biblioteca vc está usando? Link.

Veja se nela tem exemplos básicos de uso do display, e tente o mais simples para

ver se o display funciona corretamente.

Participo do fórum arduino.forum  e lá tenho lido muitos problemas com esta versão 2.0 da IDE.

Já tentou remove-la e instalar a 1.8.19?

RV mineirin

Oi, consegui fazer funcionar!

Tem um maker fantástico que está fazendo vários projetos com este display. Aqui o link do vídeo dele:

https://www.youtube.com/watch?v=gpyeMjM9cOU&t=338s

Eu desinstalei o Arduino IDE 2.00 e instalei o mesmo que o Volos usou V1.8.12, do zero e segui passo a passo o video dele.

Funcionou!  Display espetacular! 

Vou me inscrever nesse forum do arduino! Muito obrigado!!

Pergunta: qual a versão mais estável antes desta 2.00? Seria a 1.8.19?

Bom dia.

Sim, 1.8.19

RV mineirin

Funcionou também com a V 1.8.19!

Muito obrigado! Boa sorte a todos, excelente placa!

Como funcionou com a versão 1.8.19 e não funcionou com a versão 2.0,

sugiro que se você se cadastrar no  fórum do arduino, reporte lá a sua experiência

com este produto e com as 2 versões.

Isto ajudará os desenvolvedores da versão 2.0 a procurar e corrigir bugs.

https://forum.arduino.cc/c/software/arduino-ide-2-0/93

RV mineirin

Obrigado, vou fazer isso!

Boa tarde.

Vi lá no fórum o seu tópico.  Legal 

O pessoal do time do arduino está solicitando uns procedimento para identificar o problema.

O Sr. já viu lá o pedido deles?

RV mineirin

Vou lá agora! Obrigado!

Ola, 

Eles analisaram o problema, parece que a biblioteca TFT_eSPI  V. 2.4.72 não funciona com esta placa.

A recomendação é copiar e colar a biblioteca TFT_eSPI V.2.4.71, que funciona, sobre os arquivos da V.2.4.72, mudar a placa para outra qualquer, pedir para "Verificar/Compilar" (isso faz com que o cache do IDE seja preenchido com os dados da V2.4.71), mudar para a placa T-Display e na sequencia fazer upload.

Feito isso,  A V.2.0.0. começa a funcionar!

Para mais detalhes: 

https://forum.arduino.cc/t/arduino-ide-2-00-and-lilygo-t-display-es...

RSS

© 2022   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço