ESP8266 Node MCU programa desaparece se desliga a USB ?

Olá pessoal, bom dia, sou novato no ramo e estou enfrentando o seguinte problema, faço meu programa dou upload pro NODEMCU e ele funciona perfeitamente, porem se tiro da USB e religo o programa para, a impressão que tenho é que o sistema é apagado ou algo do tipo, porque isso acontece ? sera defeito do meu ou isso realmente acontece ? Tem como corrigir ?

Obrigado e grande abraço a todos !

Exibições: 202

Responder esta

Respostas a este tópico

Bom dia LS,

Qual IDE você está usando pra programar o NODEMCU?
Como você percebe que o programa desapareceu?

Faça um teste simples.

Grave um blink, e veja se funciona legal.

Anexe (não cole na área de texto) o seu sketch pra que possamos dar uma olhada nele.

Rui

Olá Rui,

Estou usando o IDE do Arduíno versão 1.6.13, isso acontece com qualquer programa, eu ja testei com blink mas o atual que estou testando é esse (tocar do re mi fa bem simples),

void setup()
{
pinMode(0,OUTPUT); //Pino do buzzer
}

void loop()
{
delay(2000);
tone(0,262,200); //DO
delay(200);
tone(0,294,300); //RE
delay(200);
tone(0,330,300); //MI
delay(200);
tone(0,349,300); //FA
}

LS,

Faça uma atualização do firmware do NODEMCU, e veja se resolve.

Rui

Olá Rui

Fiz a atualização seguindo os passos https://hackaday.io/project/3465-playing-with-esp8266/log/12683-dow... porem o problema continua, estranho que nem sempre foi assim, nao lembro quando começou a fazer isso.

Abraço

Oi LS

Já experimentou com uma versão mais antiga da IDE ?

Rui


ESP8266 - Usando IDE Arduino (exemplos ADAFRUIT/SPARKFUN )
http://labdegaragem.com/forum/topics/conhecendo-o-esp8266?commentId...

ESP8266 - Teste de comunicação serial do Arduino com o ESP8266 :
http://labdegaragem.com/forum/topics/conhecendo-o-esp8266?commentId...

Muitas informações sobre o ESP8266 :

http://labdegaragem.com/forum/topics/conhecendo-o-esp8266

Olá Rui e Jose Gustavo, muito obrigado pelo apoio, fiz alguns tentes e aparentemente resolvido !, eu estava com o Buzzer e depois os Leds ligados na GPIO0 (flash) acredito que pelo fato de ser uma porta flash quando iniciava apagava tudo, agora troquei a porta e a programação não é mais apagada ! Vocês que conhecem mais era isso mesmo ? nao podemos usar a GPIO0 ? abraço

Valeu !!!!

Módulo ESP8266 ESP-201 - descrição e uso:
http://labdegaragem.com/forum/topics/conhecendo-o-esp8266?commentId...

IO_0 ( GPIO_0 / Pino 15 do Chip): Atenção !
Obdecendo configuração do firmware, para boot da memória Flash durante o reset, esse pino deverá ter o nível alto - conecte um resistor de 10K ohms ao +3,3V. Mas para gravar a memória Flash usando o modo de download através da interface serial UART, esse pino  deverá estar no nível nível baixo (zero Volts - conectado ao terra).


RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2018   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço