Bom dia... 

Estou tendo um problema quando eu coloco o meu esp8266 v3 como access point, quando ele esta comunicando com o meu roteador wifi a comunicação é estavel, mas quando coloco ele como access point a comunicação com o Pc fica caindo e com o celular a comunicação inicia e imediatamente cai. 

Por favor, alguém poderia me ajudar?

-- Programa: Web Server com ESP8266 Nodemcu
-- Autor: Diego Rocha

-- Conexao na rede Wifi
wifi.setmode(wifi.SOFTAP)
print(wifi.ap.getip())
-- Definicoes do pino do led
led1 = 1
gpio.mode(led1, gpio.OUTPUT)
-- Definicoes do Web Server
srv=net.createServer(net.TCP)
srv:listen(80,function(conn)
conn:on("receive", function(client,request)
local buf = "";
local _, _, method, path, vars = string.find(request, "([A-Z]+) (.+)?(.+) HTTP");
if(method == nil)then
_, _, method, path = string.find(request, "([A-Z]+) (.+) HTTP");
end
local _GET = {}
if (vars ~= nil)then
for k, v in string.gmatch(vars, "(%w+)=(%w+)&*") do
_GET[k] = v
end
end
buf = buf.."<h1><u>CHÁCARA SÃO VICENTI</u></h1>";
buf = buf.."<h2><i>ESP8266 Web Server</i></h2>";
buf = buf.."<p><a href=\"?pin=LIGA1\"><button><b>LED 1 LIG</b></button></a> <br/><br/><a href=\"?pin=DESLIGA1\"><button><b>LED 1 DES</b></button></a></p>";
local _on,_off = "",""
if(_GET.pin == "LIGA1")then
gpio.write(led1, gpio.HIGH);
elseif(_GET.pin == "DESLIGA1")then
gpio.write(led1, gpio.LOW);
end
client:send(buf);
client:close();
collectgarbage();
end)
end)

Exibições: 53

Responder esta

Respostas a este tópico

Bom dia DR.

1a recomendação:  Leia http://labdegaragem.com/forum/topics/sugest-o-de-como-postar

SGNAA

Boa tarde, realmente esta difícil de entender. 

Use a ferramenta WIFI Analyzer para saber se uma rede esta usando o mesmo canal da outra. 

https://play.google.com/store/apps/details?id=com.farproc.wifi.anal...

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2017   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço