Bom dia a todos!

Gostaria de uma ajuda em um projeto que eu montei, não sei se tem solução sem trocar os relés mas pode ser q alguém já tenha passado por isso e saiba como resolver. 

Eu tinha um arduino uno e um módulo RTC parado e montei um timer para controlar a iluminação do meu aquário. Comprei 4 relés 5V da marca Songle. Fiz uma ligação bem simples do relé ligado direto no GND e em uma porta digital. Está funcionando tudo corretamente, porém o relé parece q agarra as vezes e não desliga o circuito no horário programado. Parece ser algo mecânico pq basta eu dar uma leve batida na caixa da montagem que o circuito desliga a iluminação. 
Também não acredito que seja sobrecarga pq o relé suporta até 10A e está ligado 4 lâmpadas de 6W em um relé, 2 lampadas de 50W em outro e uma fonte 12V que alimenta uma solenoide em outro relé. 


Minha dúvida, exite algum componente (resistor, capacitor, etc) que eu possa ligar em paralelo nos terminais da bobina do relé que possa resolver isso? 
Se não tiver jeito de resolver e só trocando os relés mesmo vcs acreditam que seria melhor comprar um módulo de relés já pronto para arduino ou utilizar relés de estado sólido, pensei nos da marca Fotec. 

Agradeço qualquer ajuda. 

Exibições: 117

Responder esta

Respostas a este tópico

Olá.

  O funcionamento de um rele é bem simples do ponto de vista do usuário, mas do fabricante é ago mais complexo.

  Quando vc liga uma carga é comum termos uma fagulha. Essa fagulha provoca destruição da superfície do contato. Como uma pequena solda elétrica que tanto solda (cola) os contatos quanto pode provocar oxidações isolantes (não liga mais).  

  Para aumentar a vida útil do rele o bom fabricante adota várias técnicas como recobrir o contato com matérias de qualidade maior como o tungstênio, ouro, etc, usar um braço que liga a parte magnética a parte de contato com flexibilidade, que ao envergar faz com que o contato seja único (sem repique) e alem de encostar provoque um "esfregar" para o lado, que gera uma auto limpeza, etc. Ou ao contrário fabricantes capricham para que não se mova depois de encostar para não desgastar. Depende do fabricante, se tem foco em alta corrente ou alta tensão, etc.

   Agora, pra economizar... vale tudo. 

   Fato é que as cargas geram essas faíscas. Se for uma lampada incandescente ela possui uma corrente inicial maior que a de trabalho pq o metal está frio. Se for uma fonte chaveada ela possui uma corrente maior pq os capacitores estão descarregados (as lampadas led modernas possuem uma fonte chaveada), se for um motor  possui pq é preciso mais energia para acelerar, etc, etc. Em geral a corrente inicial é maior que a corrente nominal.
    Vc deve estar sofrendo por esse tipo de faísca de contato em um relé ruim.
    Formas de atenuar:
    Se houver envolvimento de alta tensão, gerada por um indutor, como o solenoide citado, é necessario incluir um snubber. Ele é colocado em paralelo com a carga. Em raros casos em paralelo com o contato.

    https://pt.wikipedia.org/wiki/Snubber

    Vc compra ele já montado, com esse nome, em lojas de peças para refrigeração. 

    Sensor Filtro Supressor Snubber Rc Full Gauge 5w - FrioshoppingFrete Grátis! 10pc solenoide indutivo carga rc snubber circuito relé de proteção de contato interruptor módulo de circuito sensor|sensor sensor|relay sensorload sensor - AliExpress

  Ou vc pode montar ele com componentes de mesmo valor.

   

   Eles são eficientes para cargas indutivas, mas para cargas do tipo lampadas LED, que muitas vezes tem uma fonte simples, diodo e capacitor de alta tensão, que tem que se carregar de 0 até a tensão de pico da rede eles são pouco eficazes. O ideal seria algo em série, mas não recomendo pq pode esquentar. Nesses casos tem 2 possibilidades:

   Rele de melhor qualidade (fabricantes melhores) ou acionamento por tiristor ou coisa assim. Vc pode comprar de forma simples um rele de estado sólido:

Relé de Estado Sólido 380V 100A Controle 3 a 32V - SSR-100DA

   Não sei se entendi bem, parece que vc disse que ligou o rele direto no arduino. Acredito que vc tenha ligado o modulo rele, que possui internamente um transistor. Ligar direto o rele no pino do microcontrolador não é recomendado.

   

Obrigado Eduardo, sim eu liguei direto mesmo na porta digital do arduino. Nesse caso se eu utilizar um módulo relé pronto igual esse da foto resolveria o problema? 

O componente rele vc não pode ligar direto no arduino. Ainda que ele suporte a corrente da bobina é preciso um diodo para evitar a corrente reversa

Não sabemos o motivo do travamento, pode ser que não resolva.

Mas é obrigatorio vc usar esse circuito que vai aih no modulo, seja bom assim, com um optoacoplador, ou ainda mais simples, só com um transistor. 

Então a sugestão é trocar.

Pode ser que resolva mas depois de um tempo volte a dar problema. 

Para vc ficar garantido vc pode já por o snubber em paralelo com a carga que é indutiva (solenoide).

Colocar uma lampada incandecente em paralelo com a carga indutiva também pode resolver. O filamento faz a função de limitar a tensao quando o indutor é desligado.

Vou trocar para o módulo e procurar o snuber. Mas não acredito que a solenoide seja o problema pq ela não está sendo alimentada direto, ela usa uma fonte de 12V, o relé está alimentando a fonte. 

Se não está direto realmente não é isso.

Mas de qq jeito é recomendado usar um módulo de rele, vc pode queimar seu arduino ligando direto.

Bom dia, 

Qual driver usou para acionar os relés?

Sugiro que use um módulo Relé e uma fonte externa de 5V para alimentar esse módulo. 

Boa noite!

Comprei um módulo relé de 4 canais optoacoplado, montei tudo mas o problema ainda persiste. 
O problema está sendo só com as lâmpadas de led normal, os outros 2 relés 1 ligado a uma fonte 12V e outro a 2 lâmpadas ledgrow de 24W não estou tendo problemas. 
São deste modelo abaixo, 4 lâmpadas de 6W.

Estou na dúvida se parto para o snuber mesmo ou se tempo usar um transformador isolador nessa lâmpada.

Olá amigo, desenha numa folha de sulfite como está ligado pra ver se está tudo em ordem. Mas pra adiantar, faça o acionamento de potência primeiro, teste de forma manual. Nesta fase meça a corrente, pra saber se o contato do relé vai aguentar (se for muito considerar usar um relé adequado). Com a lâmpada acionando de forma manual, agora sim a gente vai ligar no relé. Nesta fase o acionamento ainda é manual, joga a tensão de controle na bobina, direto mesmo (geralmente 5v). Pronto, acionando manualmente faça um código simples piscando alguma saída do arduino de 5 em 5 segundos pra acionar / desacionar... Fazendo desta forma poderá localizar o problema, por etapas. Não vai precisar, mas se quiser calcular o circuito pode usar um pedaço de um vídeo que fiz, faz tempo, qualidade péssima, mas se precisar passo de novo de forma mais clara. Desenvolvi uma forma de usar qualquer rele a partir do valor de resistência dele.

https://youtu.be/ew7-9gwv44E?t=278

Olá, Alan!

Usando a sugestão do Renato Portugal você ainda tem a vantagem de saber se o problema é hardware ou software.

Se, com os testes simples que ele sugeriu, as lâmpadas funcionarem bem, talvez seja uma boa idéia procurar o problema no código.

RSS

© 2021   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço