Bom dia pessoal, gostaria de pedir uma ajuda ou uma dica de quem já trabalha com estes Esp01.

     Estou fazendo aqui uma plaquinha que vai conter um esp01 e um Relê pra ser acionado com um pulso para abrir o portão da casa. O problema é que ao ligar a placa o esp01 já envia um sinal e aciona o relê assim sempre que for desligado e ligado por algum motivo o esp01 já envia um sinal na porta Digital e assim o portão irá ser acionado.

     Gostaria de pedir uma dica dos amigos como faço para o Esp01 ao ser ligado não fazer nada na porta D0 ou D2 para que este problema não ocorra.

aqui abaixo em anexo postei um código do blink que estou usando pra testar esta inicialização, desde já agradeço a ajuda.

Exibições: 61

Anexos

Responder esta

Respostas a este tópico

Bom dia CRB, (se não gosta que te chame pelas iniciais, avise),

Recomendações:
1. Remova seu sketch da área de texto do seu tópico;
2. Leia http://labdegaragem.com/forum/topics/sugest-o-de-como-postar
3. Comente as linhas do seu sketch. Fica mais fácil entender o que vc quer fazer com cada
     linha e facilita a ajuda.
4. Clique em : " Deseja carregar arquivos? " e depois em " Escolher arquivo" e anexe o arquivo
com o seu sketch.

RV mineirin

bom dia, não tem problema em abreviar meu nome, e desculpe eu não sabia que tinha estas regras. foi corrigido. obg

bom dia sr. José Gustavo, quero agradecer pela sua atenção que da aos visitantes deste fórum e sempre que preciso o sr. sempre está disponível pra ajudar aqui.

Irei ver os tópicos que sugeriu. Tenha um ótimo dia.

Bom dia CRB, 

veja se esta tabela ajuda você entender como cada GPIO fica em cada situação.

RV mineirin.

Ref: https://rabbithole.wwwdotorg.org/2017/03/28/esp8266-gpio.html

Bom dia CRB, 

Os ESP8266-01 só tem os GPIO0, GPIO2 e GPIO3 acessíveis ao projetista.

RV mineirin

RSS

© 2021   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço