Basicamente quando a variavel "ponto1" for ==1, ele deveria ir pro void cartaoSD(), e escrever algo no cartao SD, já verifiquei se era chavetas e nao, definicao de variaveis, tmb nao, ja defini o nome da pasta onde deve escrever e simplesmente nao escreve, estarei deixando uma copia do meu codigo para darem uma olhada. desde já obrigado.

Exibições: 233

Anexos

Responder esta

Respostas a este tópico

Olá, João!

Acho que o compilador tem uns avisos para você.

Mas você tem que estar receptivo aos avisos para recebê-los.

Na IDE do Arduino vá em File -> Preferences e marque a caixa show verbose output during [] compilation, caso ainda não esteja marcada.

Também mude a chave Compiler warnings para All, caso esteja com outra seleção.

Depois, faça um Verify no seu programa ( primeiro ícone no canto superior esquerdo da tela da IDE ).

Na janela Output ( parte inferior da tela da IDE ) vai aparecer os avisos que o compilador tem para ti.

Leia-os com atenção. São muito úteis.

D. T. Ribeiro.

Verdade, está tudo lá...

Certamente vai estar, por ex, alertando que:

Na linha:

if (ponto1 = 2)
Para uma comparação se usa "==" e não "=".

Olá muito bom dia, coloquei tudo de acordo como me alertaste, e continuo com o mesmo erro, eu estou a usar o exemplo "Card Info" para ver se está tudo bem, mas ele imprime que dentro do cartão está uma serie de caracteres estranhos.

outro ponto estranho quando vou abrir a "file" que criei no codigo mas ele diz:

"Erro ao abrir a file"  e a seguir ele diz:

"text.txt" que supostamente diria isso quando fosse aberta a file, resumindo diz que nao foi possivel abrir enquanto a seguir diz que escreveu, e nao escreveu nada no cartao SD.

Bom dia.

Qual plataforma voce está usando?  ESP32?

Poste um esquemático do seu projeto, (mesmo feito a mão livre), isto ajuda  entender melhor

e permite melhor ajuda.

RV mineirin

Olá boa tarde, já resolvi o problema anterior, o meu modulo necessitava de 2 GND´s, o que achei bem incomum, mas erro de minha parte por não ter prestado atenção a esse detalhe, só reparei nisso graças ao "D. T Ribeiro", que fez-me perceber que não era problema de código e sim de montagem, mais uma vez obrigado pelo seu tempo.

RSS

© 2024   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço