Boa tarde pessoal, alguém ja trabalhou com este conversor rs232?

To tentando receber os dados da porta RS232 de de uma balança para o ESP8266, porem não me da retorno nenhum.

To tentando utilizar os exemplos da SoftwareSerial Library, e nada!!

Exibições: 1046

Responder esta

Respostas a este tópico

Segue as fotos

Olá,

  • Acho que está errada a sua conexão com ele.

    Vou te explicar.

  • Os GPIOS1 e GPIO3 são da UART nativa (Serial nativa) do ESP, então voce não pode

    usa-los na sua softserial.
  • Tem que escolher outros GPIOS

    Se for usar o GPIO1 e o GPIO3 então não precisa de softserial.

  • Mas não pode usar os GPIO1 e GPIO3 com a balança e com o USB comunicando, pois o NODEMCU usa os GPIO1 e GPIO3 para comunicar com a USB.


    Vc está tendo um conflito de "interesses " entre a USB e a balança.

    RV mineirn

Hoje chegou o cabo para conectar ao PC, e recebi os dados da balança perfeitamente, liguei novamente o max3232 agora no arduino UNO, e obtive estas respostas

12:53:58.081 -> 0
12:53:58.128 -> 0
12:53:58.173 -> 0
12:53:58.265 -> 0
12:53:58.311 -> 0
12:53:58.358 -> 0
12:53:58.405 -> 0
12:53:58.451 -> 0
12:53:58.544 -> 0
12:53:58.591 -> 0
12:53:58.638 -> 32
12:53:58.685 -> 0
12:53:58.777 -> 0
12:53:58.823 -> 0

Sera que e algum problema com o max3232 

Bom dia ,

que cabo é este? Tem um datasheet ou link com foto dele?

RV mineirin

Acho que esse programa não tem como funcionar... (sketch_mar13a.ino)

Ele abre a Soft serial no mesmo pino da seria física.

Alguém aqui já alertou sobre isso..

O ESP32 tem inúmeros pinos reservados que vc não pode usar pra uma coisa ou pra outra.

Vc precisa usar um pino livre de tudo.

Como saber se o pino está comprometido:

Vide essas imagens com as funções de cada pino.

https://www.upesy.com/blogs/tutorials/esp32-pinout-reference-gpio-p...

Ainda, ele possui mais de uma serial em hardware. Melhor sempre usar em hardware;

Ref:

https://circuits4you.com/2018/12/31/esp32-hardware-serial2-example/

Outra coisa:

Vc já detectou que o "led pisca" entre o fio verde e o preto. Isso é ótimo sinal.

Mas ele precisa piscar também depois do seu módulo RS3232. Possivelmente só vai piscar entre VCC e RXD ou TXD.

Vale verificar com o multimetro se não há inversão nos fios.

Tem maluco pra tudo...

Pode ser que o pino TX do seu módulo na verdade seja o RX e vice versa.

Pode ser que o pino TX da sua balança sena na verdade o RX (indicando: Ligue aqui o TX).

Essa questão da necessidade de ligar TX com RX aflige mto o hobbista, pode ser que o módulo já tenha feito essa inversão querendo dizer: "Ligue o TX aqui".

Enfim, certifique-se que esse fio verde, que traz os dados, vai em um pino de entrada RS232 do integrado e verifique saída correspondente onde vai dar.

Digo isso pq o seu fio verde nitidamente transmite, é um TX, e está ligado ao pino 2 do seu conector, que tem nome de RX... 

Como o fio teria que ser cruzado (TX com RX) podem ter poupado o usuário dessa preocupação e feito a inversão internamente (da balança).

Ja vi estas questões e pinagem, para desencargo de consciência, resolvi testar tudo no UNO, e mesmo assim não deu nada. 

Sobre a questão dos LEDS, hoje de manha resolvi testar no RS3232, e não piscou em lugar nenhum, nem no RX e nem no TX, ai deduzi que deve ter algum problema no modulo.

comprei duas versões do RS3232 para ver o qe acontece


E esta bendita novamente, e vamos ver o que vai dar


Vi em um forum sobre o teste de led

 E não tive nenhum resultado

Bom dia,

agora que voce tem um cabo USB <==>RS232, voce pode usa-lo para testar seu modulo.

Ligue se cabo USB/RS232 com USB no PC e o RS232 no seu modulo.

Use seu arduino UNO com softSerial e fique mandando dados para o PC,

mas de um delay entre um envio e outro pra esperar a Serial terminar, pois em 9600 ela é um pouco lenta, ainda mais com softserial.

No PC use este mesmo software que usou na balança e veja se chegam dados no PC.

RV mineirin

PS:

Algo similar a isto:

Bem pensado, testei ele recebeu, mas com caracteres estranhos

modelo_balanca.ino

Depois de uma grande ajuda do @mineirin RV, descobrimos que o max3232 esta funcionando normalmente, testamos com o CABO USB conectado diretamente ao max3232, dados enviados e recebidos normalmente, agora tenho que descobrir se e alguma configuração na balança para enviar para o modulo max

esta e a única coisa que esta dando problema agora

Pode ser que usando o led no GND-> pino não pisque mesmo.

Pq a saída do TX e RX pode ser "open colector". Essa forma é usada para proteger a porta, evitar que queime.

Se for assim só existe o transistor que joga para gnd. Vc faz o nivel 1 com um pullup, ou liga o pullup interno do microcontrolador.

Se for isso vc precis colocar o anodo no Vcc e o resisitor (catodo) no pino sendo testado.

RSS

© 2024   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço