[RESOLVIDO]Circuito DC com Spikes (ruído) travando meu ESP32

Salve pessoal
Estou acionando um motor elétrico usando ESP32 e um relé para suportar a corrente, a fonte é uma bateria de 12V com carregador de 13,8V, porem as vezes quando o relé desliga, o processador trava. Alguém pode me dar uma ideia de onde estou errando?
Abs.

Exibições: 333

Responder esta

Respostas a este tópico

Bom dia,

o que está causando o travamento são os "spikes" (ruídos elétricos) gerado na abertura e fechamento

de reles com cargas indutivas.

Para minimizar estes "spikes", sempre recomento o uso de "snubbers" em paralelo com os contatos do rele.

Veja este artigo:  ele ajuda a entender e minimizar o problema.

https://pt.wikipedia.org/wiki/Snubber

Depois conta o resultado pra gente.

RV mineirin

Muito obrigado pela dica.

Pretendo aplicar essa solução por ser muito parecida com o meu problema e depois mostro o resultado.

 
https://youtu.be/avBMOlJYvu0?t=377

Boa tarde,

esta "tipo de snubber" só é possível se voce usar o motor em uma direção somente, 

se for usar inversão de direção é recomendado o uso de snubber RC.

RV mineirin

Boa noite.
O motor gira em apenas um sentido e atendeu exatamente o que eu precisava.
O circuito ficou estável e perfeitamente funcional.
Sua dica me ajudou muito para melhorar minha pesquisa e resolver esse problemão.
Muito obrigado!!

Olá Carlos, caso seu problema tenha sido resolvido, sugiro:

1- Adicionar um "[resolvido]" no início do tópico.

2- Aprimorar o título do tópico para que outros membros possam encontra-lo, exemplo: "Circuito DC c/ motor, travando o esp32 (Problema spikes)"

Valeu pelas dicas e acabei de realizar as alterações sugeridas.

RSS

© 2024   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço