Boa tarde

Eu tenho alguns ventiladores arno ultimate e eu pretendia automatiza-los quando chegasse a temperatura x eu ligasse todos os ventiladores da casa entao eu comprei um daqueles sensores de temperatura e essa parte funcionou como eu esperava . Mas estou tendo alguns problemas para fazer um transmissor . Eu sei que o controle não é infravermelho porque não emite luz e não precisa de visada. Eu acho que ele é semelhante a um controle de garagem . Eu tentei um receptor de 433Mhz e outro de 315 e nenhum deles parece ler emissões  do controle. eu anexei uma foto do controle e minha pergunta é olhando ele tem como saber qual frequencia ele opera ou como eu posso descobrir isso ?

Obrigado

Exibições: 2382

Anexos

Responder esta

Respostas a este tópico

Para dar uma atualização no andamento

eu fiz o receptor usando o ht12e usando esse esquema

https://electronics4ubymanmohanpal.blogspot.com/p/blog-page_19.html

e um receptor de 433MHZ e eu leio uns valores que mudam toda vez que eu aperto um botao . Já é mais do que eu tinha ate agora .

O controle permite 16 configurações diferentes para controlar até 16 ventiladores . Eu reparei que ao ler o led acende rapidamente do mesmo jeito que a chave está selecionada . então imagino que se eu fechar as portas correspondentes eu controlo ventiladores diferentes (eu tenho 4 iguais , cada um numa frequência)

Muitos componentes estão raspados propositalmente isso complica muito

Boa tarde 

"eu fiz o receptor usando o ht12e usando esse esquema" 

Incorreto! - O receptor tem que usar o chip HT12D.

vc esta certo , falha a minha

Olá Gustavo, tudo bem?
Teve algum progresso nesse projeto?

Tenho um ventilador destes e gostaria de automatizar também.

No meu controle (PE-128 2012.08.18 VER.B) usa o chip:

SONIX

SN8P2612SG

1549NCZ0C

Eu acabei comprando um aparelho de ar condicionado e uma alexa faço via internet mesmo

Oi, Gustavo, tudo certo?

Creio que você já finalizou esse projeto, porém vou postar um projeto que fiz com o mesmo ventilador aqui, para que outras pessoas possam vir procurar pelo conteúdo.

Eu acabei queimando um controle desses ao tentar ligá-lo a um esp32. Comprei um controle novo e capturei o sinal enviado ao chip rf, no meu caso um ndr4003, com o auxílio de um osciloscópio.
Atualmente estou usando a parte rf do controle queimado ligado ao esp que envia o sinal copiado. Como o esp tem wi-fi integrado existem várias funcionalidades que podem ser adicionadas mas por equanto uso apenas pra enviar comandos pelo celular.

Alguém pode me indicar um jeito bom pra compartilhar os arquivos do projeto?

Valeu

Olá Samuel, o jeito que eu recomendaria seria usando o GitHub, pois da uma visibilidade para o seu trabalho e facilita a colaboração. Se vc nunca trabalhou com git ou tiver dificuldades, pode anexar aqui no tópico ou me mandar por mensagem que eu compartilho no GitHub com os devidos créditos. 

Boa noite Samuel, tudo tranquilo?

Você compartilhou o código de seu projeto em algum lugar? Tenho interesse para poder automatizar meu ventilador aqui de casa e talvez adicionar suas funcionalidades a algum assistente virtual.

Desde já obrigado!

Oi,

desculpe pela demora. Acabei de ver as mensagens aqui.

Seguindo a recomendação do Ricardo, subirei o conteúdo neste repositório: https://github.com/samuelkato/arno-vx10 . Ainda estou organizando os arquivos pra ficar um pouco mais inteligível haha.

Pedro, caso te interesse, posso criar um outro repositório com conteúdo para conexão com a alexa usando esp32/esp8266. Porém, creio que por algum bug, eu só consigo criar 2 comandos por chip.

Valeu

Olá Samuel,

Obrigado por compartilhar seu projeto. Você sabe como está a posição das chaves de configuração do seu controle?

Eu não consegui fazer funcionar aqui, meu controle está configurado com as 4 chaves para baixo.

Opa, a documentação estava incompleta, acabei de atualizá-la.

Olá Samuel,

Apenas para dar um retorno, consegui fazer funcionar com o seu código obrigado!

Eu usei um transmissor RF 433 desses baratinhos do AliExpress.

Antes não tinha funcionado pois eu não tinha soldado a antena na plaquinha transmissora, eu testei com a placa ao lado do ventilador, mas mesmo assim não funcionou. Depois que eu soldei a antena funcionou de primeira.

Agora vou tentar simplificar, ver se é possível funcionar todos os comandos com tempo múltiplo de 500ms e tentar ler os comandos com aquelas chavinhas em outra posição, pois eu tenho 2 ventiladores aqui em casa. Se eu conseguir algum resultado eu posto aqui.

RSS

© 2021   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço