Estou com a IDE do Arduino devidamente instalada e configurada no meu computador.

Ele reconhece a porta no qual a placa Arduino Nano está instalada (ATmega328 - old bootloader); o driver CH340 está instalado e devidamente reconhecido na porta COM3; o cabo de ligação não apresenta problemas; acendem dois leds (um vermelho e outro verde) na placa indicando a energização; o programa blink carrega e é executado na IDE; a velocidade de 115200 está configurada no programa Universal G-code Sender e ele funciona também neste computador.

Porém, nenhum dos leds da placa do Arduino pisca de acordo com o tempo configurado. Já mudei o tempo das piscadas do led no programa para saber se não estou conseguindo enxergar devido estar muito rápidas as piscadas, mas nada acontece.

O chip do meu Arduino Nano é o CH340G. Tem diferenças com o CH340 ?

Preciso utilizar este Arduino para um projeto de máquina CNC.

Há outras experiências que posso fazer além da execução do blink para saber se a placa não apresenta algum defeito ?

Observando todos os arquivos da IDE do Arduino, não vejo nenhuma identificação do drive CH340G, apesar que no gerenciador de dispositivos do Windows 7 aparece o drive instalado na COM 3. Ele tem que estar necessariamente incorporado à IDE do Arduino para funcionar ?

Quando clico em ferramentas no programa Arduino e depois clico em Obter informações da placa, aparecem o seguintes dados: BN:  Placa não identificada / VID: 1A86 / PUD: 7523 / SN: Envie qualquer sketch para obter. O que estes dados significam ?

Tentativas de atualizar drive já foram feitas. Após instalado, observando a subpasta do drive WCH.CN no disco local (C:), diz o seguinte: A versão deste arquivo não é compatível com a versão do Windows em execução. Consulte as informações do sistema do computador para verificar se você precisa de uma versão x86 (32 bits) ou x64 (64 bits) do programa e entre em contato com o editor do software. Aqui está descrito todos os problemas que consegui identificar e tentei saná-los sem êxito.

Já procurei o drive CH340G na Internet e achei dezenas de locais para extraí-lo. Porém, nenhum destes locais informa se o drive é para Windows 32 bits ou 64 bits, com exceção de um único. Então, instalei o drive x86 (32 bits) e continua o mesmo problema.

Como vou resolver a questão ? Alguém poderia me dar uma explicação útil ?

Exibições: 133

Responder esta

Respostas a este tópico

Boa tarde,

Você gravou algum firmware do G-Code Sender?

Se alterou o bootloader do Arduino NANO, não poderá usá-lo com a IDE Arduino! 

RSS

© 2021   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço