Tutorial: Como acender leds pelo Serial Monitor do Arduino

Adquira estes componentes na Loja do Lab de Garagem

Neste tutorial, vamos mostrar como acender e apagar leds digitando dados pelo Serial Monitor com Arduino. A programação é simples e bem interessante, pois com a mesma tecla, você liga e desliga o led. É uma aplicação simples mas muito útil em qualquer aplicação, seja acender apenas um led ou ligar um equipamento.

Primeiramente, faça as ligações como mostrada abaixo:

Agora, abra a IDE do Arduino e passe a seguinte programação:

char c;

void setup(){
pinMode(2,OUTPUT);
pinMode(3,OUTPUT);
Serial.begin(9600);
}


void loop()
{
if (Serial.available()>0)
{
c = Serial.read() - '0';
Serial.flush();
digitalWrite(c,!digitalRead(c));
}
}

Conecte o Arduino no PC, selecione a versão do seu Arduino (UNO, Duemilanove, etc) e porta (COMx, ttyUSBx, ttyACMx) e clique em UPLOAD. Abra o Serial Monitor e selecione 9600 no baud.

Ao digitar o número 2 no Serial Monitor, irá acender o LED conectado na porta digital 2 do Arduino, e ao digitar novamente o número 2, o LED apagará. Agora se digitar o número 3, irá acender o LED da porta digital 3 e se digitar novamente o número 3, o LED apagará.

E é isso! Bem simples! Esperamos que tenha gostado! Se tiver dúvidas, poste aqui neste blog! Para sugestões de tutoriais, clique aqui! Para ver outros tutoriais e projetos desenvolvidos pela equipe LdG e por outros garagistas, clique aqui e aqui, respectivamente! Até a próxima!

Referências:

http://arduino.cc/en/

Exibições: 27088

Comentar

Você precisa ser um membro de Laboratorio de Garagem (arduino, eletrônica, robotica, hacking) para adicionar comentários!

Entrar em Laboratorio de Garagem (arduino, eletrônica, robotica, hacking)

Comentário de JORGE AUGUSTO RABELLO PINTO em 19 maio 2017 às 21:05

Olá boa noite, vocês poderiam explicar por favor por que tem que ter o - '0' no Serial.read() ? Percebi que sem isso não funciona...

c = Serial.read() - '0';

Valeu

Comentário de Daniel de Domênicis em 19 junho 2013 às 21:42

Olá meu querido amigo Marcelo Rodrigues!

Eu comprei o kit completo, SM5100B com a antena e os 4 grampos para conectar no arduino uno, coloquei o código acima, inseri um chip da TIM e com o PUTTY fiz a conecção, só que ele responde dessa forma que está abaixo, e não me deixa digitar nada, tem algo que eu possa corrigir?

  Iniciando SM5100B Comunicacao...

   
  +SIND: 1

  +SIND: 10,"SM",1,"FD",1,"LD",1,"MC",1,"RC",1,"ME",1

  +STIN:0

  +SIND: 3

  +SIND: 4

  +SIND: 8

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2017   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço