Tem como testar se o módulo rf receptor 433MHz está pifado?

Montei os circuitos dos módulos RF cada um com um arduino uno e
gravei os respectivos códigos.
Tudo funcionou perfeitamente bem.
Troquei o arduiino do receptor por um mega2500 e tudo continuou perfeitamente.
Passei a testar as distâncias de alcance e coloquei uma antena de aprox. 17cm
no receptor.(coloquei com tudo ligado) Não alterou nada.
Mas o conjunto continuava perfeito a pouca distância.
DE REPENTE o receptor não "recebia" nada.
Troquei protoboard, jumpers, refiz tudo, verifiquei tudo e NADA.
Será que o módulo receptor "pifou"
Tem como testá-lo?
Não acho necessário mas anexei os código e circuitos.
Caso precisem deles para análise eu "colarei" no texto.
Obrigado pela ajuda

Exibições: 35

Responder esta

Respostas a este tópico

O teste perfeito seria vc ligar um osciloscopio no pino "DATA" do receptor e observar a forma de onda quando vc pressiona o botão de um controle remoto comum de mercado, funcionando e com pilha boa (garantindo que o problema não é ele).

Na falta do osciloscópio vc pode ligar um LED+resistor e terá uma ideia do sinal ali.

Faça o teste e diga que resultados achou.

Se seu receptor tiver uma bobina com um nucleo pode ser um ajuste. Eh muito ruim lidar com ele, vc precisa de uma chave de fenda não metálica. As boas são de ceramica. Na falta vc pode fazer uma apontando um pedaço de plastico. Tampa de bic serve.

Enfim, tentar ajustar sem saber o que está fazendo é acabar de destruir o receptor... Cuidado, mas quem sabe é isso. Se vc amassou uma "molinha" que tem no receptor por ex pode ter desregulado. Aquilo é um indutor.

Alguns receptores não tem ajustes.

Ref:

http://blogmasterwalkershop.com.br/arduino/utilizando-o-controle-re...

Muito grato.
Vou estudar e tentar

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2017   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço