Boa noite pessoal!

Estou rodando um Sketch no arduino que de tempos em tempos ele "trava" o Sketch consiste em acionar um rele quando o valor do  sensor PIR for 1 e consequentemente o valor do potenciometro for >=512 ou  se o valor do  sensor PIR for 1 e o valor do potenciometro  <=511. Dependendo da condição acionará o rele pelo tempo estipulado nas funções respectivas.

Não sei qual é o motivo pelo qual de tempos em tempos, não seguindo um padrão de tempo, o rele ativa e não desarma, sendo necessário resetar o sistema para normalizar.

Agradeço a ajuda de todos.

Exibições: 202

Responder esta

Respostas a este tópico

Boa tarde Argel, 

Problema mais comum - ruido elétrico provocado pelo relé .

Esta usando qual módulo de relé ?

Esse módulo de relé já tem o diodo de proteção. 

Coloque um capacitor de 1000uF/ 16V entre o +5V e o GND.

Pode ser que resolva o problema.

Abraços, 

Gustavo

Bom dia, 

Se a fonte for de 5V , pode usar o capacitor de 1000uF/6,3V

A tensão do capacitor nunca pode ser menor do que a tensão do circuito da qual será usado.

O ideal é ser o dobro da tensão. Mas para testes, pode usar esse seu capacitor.

Abraços, 

Gustavo

Boa noite Argel,

Assim fica difícil para a gente ajudar... A gente precisa saber de todos os detalhes da sua montagem.

Não sabia que tinha ligado um módulo MP3 na sua montagem.

Favor informar como é toda a montagem, qual fonte esta usando, etc.

Pode ser alguma interferência do alto-falante sim.

Parece ser falta de corrente, a fonte não está suportando a corrente exigida pelo circuito.

Monte os circuitos separadamente e veja se eles funcionam independemente, teste o módulo MP3.

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2019   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço