Ola pessoal, boa noite.
Alguns dias estou tentando fazer a leitura do sensor DS18B20 com o ci ATtiny85, mas quando vou copilar o código ele da erra, sem mostra na IDE do arduino.
Alguém já fez ou tentou usar o sensor com o ATtiny85 ?
O código esta no link de pastebin, se alguém puder ajudar, agradeço.


https://pastebin.com/PwmLNcwL

Exibições: 96

Responder esta

Respostas a este tópico

Bom dia JM,'
compilei aqui e tive problemas com a biblioteca "LiquidCrystal595.h".
Baixei a biblioteca deste link: https://github.com/dag10/EventLCD
Ao instala-la dava erro dizendo que o arquivo não tinha biblioteca valida.
Fui verificar e dentro do Zip encontrei a pasta "LiquidCrystal595".
Daí instalei manualmente e compilou seu sketch corretamente.
Rui

Ola Rui.
Mas Rui, isso no ATtiny ?
O meu não copilo nem a pau.
Estava vendo com ajuda de outra pessoa ontem, que falta espaço no ATtiny.

Oi JM,

entendi que é attiny,

configurei minha IDE como attiny, mas acho que não configurou não.

vou rever.

Rui

Bom dia JM.
conforme havia dito, revisei e consegui instalar os "drivers" do attyny.
Rodei seu sketch e compilou sem problemas:

Tela em abaixo:

Ola.
Rui, cara não estava desconfiando de você não.
Vou copilar novamente.
Você vez alguma alteração no sketch ?}
Grato.

Eu juro que não estou envolvido na LavaJato.

kkkkkkkkkkkkkkkkkkkkk

Não, é o seu sketck original.

Rui

kkkkkkkkkkkkkkkkkkkk
Cuidado hein, qualquer coisa agora é suspeita.
Vou rever tudo novamente.
Obrigado.

Rui, ola o erro que fica dando.
Tirei um print da tela.

Anexos

Boa noite JM.

Não vi erro nenhum

A compilação completou, pois até disse o tamanho que o fonte ficou.

A linha vermelha não é erro não.

É o local onde está a sua IDE.

Rui

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2017   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço