Alguém conhece o scadabr e sabe como usa-lo, caso conheça por favor entre em contato pois preciso de algumas informações.

Uma delas é o protocolo modbus pois queria saber como comunicar um sensor,atuador,etc como o supervisor por meio de um microcontrolador ou coisa paracida, me parece que para poder acionar ou receber informações o supervisorio precisa de um clp (que é caro) ou por um microcontrolador?

se alguém tiver informações sobre como usar e implementar ou pelo menos mostrar o caminho das pedras já agradeço.

adriano

Exibições: 90372

Responder esta

Respostas a este tópico

Você possui algum exemplo para eu  analisar ?

Já tentei tantas possibilidades, que acredito que neste momento eu esteja perdido, rodando em circulos

Rodrigo,

li parte do código. Tem estrutura semelhante ao que já conheço.

Mas vamos facilitar?

Escreve ai no google sarmento biblioteca arduino modbus.

Vai achar o github dele. Não sei se pode colocar o link aqui.

Esse ai é o que eu uso e ai é muito mais fácil para mim ajudar.

Obrigado Sidney

Realizei o código Abaixo.

Consigo visualizar via conversor USB 485 que o CAS Modbus envia o link e o UNO responde a um link, contudo a leitura final é sempre erro.

Estou lendo um sensor na A1, na velocidade de 9600, 8N1

[17:59:48] Recv error: Invalid function code
[17:59:44] <= Response: 00
[17:59:43] => Poll: 01 03 00 00 00 64 44 21

Código:

#include <Modbus.h>
#include <ModbusSerial.h>

const int SENSOR_IREG = 100;
const int sensorPin = A0;

ModbusSerial mb;

long ts;

void setup() {
    mb.config(&Serial, 9600, SERIAL_8N1);
    mb.setSlaveId(1); 

    mb.addIreg(SENSOR_IREG);
   
    ts = millis();
}

void loop() {
     mb.task();
   
   if (millis() > ts + 2000) {  
       ts = millis();
            mb.Ireg(SENSOR_IREG, analogRead(sensorPin));
   }
}

Rodrigo,

então sua configuração no ScadaBR é que pode estar com problemas.

Já conseguiu resolver o problema? Estou revisando os emails agora e vi que já é antiga a mensagem.

Bom dia a todos, tenho o meu projetinho rodando com 3 arduino ( 2 mega e 1 uno) com modbus serial usando o codigo aqui do lab. Adiquiri um arduino due e gostaria de coloca-lo também na rede. A ide que uso é a 1.0 mas agora com o DUE não está dando certo. Alguem já conseguiu rodar o code na IDE 1.5 ou superior?

Juliano tente usar o codigo do professor andre sarmento acho que este deve funcionar bem 

https://github.com/andresarmento/modbus-arduino/blob/master/LICENSE...

Ok, obrigado Adriano. vou tentar substituir nos que estão rodando atualmente e depois tentar incluir no DUE.

Puxa vida, vou ter que pedir ajuda aos universitarios!!!! Baixei e tentei compilar um exemplo da biblioteca do prof. sarmento. Oque acontece ? Quando seleciono por exemplo a placa arduino mega, o programa compila legal. Já quando escolho a placa arduino duemilinova, da erro no compilador.

http://labdegaragem.com/forum/topics/scadabr?id=6223006%3ATopic%3A1...

Entao ta ai o link da soluçao que normalmente funciona.
Se der alguma coisa errada reinstala

Bom dia Adriano, como havia comentado, a comunicação serial funcionou. Mas agora apareceu do nada um outro problema. O Scada nao quer iniciar. O tomcat inicia, mas o ScadaBr não, aparece a mensagem " HTTP Status 404 - " quando coloco locallhost:8080/ScadaBR. Lembrei que este foi o problema que aconteceu quando formatei meu SDcard. Estranho que até ontem estava funcionando. Notei tambem que quando executo o catalina.sh o tomcat nao inicia, so inicia quando executo o arquivo startup.sh. Vi em foruns que este é um problema comum, mas parece que ninguem tem a soulução. Agora nao sei se desinstalo tudo e instalo novamente ou tem algo que eu possa fazer, visto que vou perder novamente todos meus datapoints. 

SE vc ta usando linux, derepente alguma pasta esta sem direito para ser utilizada, procure entrar na pasta scadabr (se for linux) e digite o seguinte comando

root# chmod 777 -R "nome da pasta"

esse comando vai liberar todas as pasta do scadabr

a mensagem status 404 diz que e erro no cliente, o que e provavel que a pasta nao esta liberada.

Use o comando:

root# ls -la

este comando mostrara se a pasta scadabr esta impedida de funcionar direito, no ubuntu a pasta fica em vermelho o que significa que ela esta impedida de funcionar, ai quando vc dar o comando ela fica verde o que significa que ela esta liberadona.
DETALHE: se a pasta scadabr esta liberada mas esta dentro de outra pasta que esta impedida ela nao vai funcionar do mesmo jeito, vc tera que liberar a pasta em vermelho(nem todos os sistemas linux, deixam em vermelho).

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2019   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço