Boa galera!

Recentemente inicie um projeto para controlar um gerador de eletricidade a gasolina.

Desenvolvi dois sensores de tensão com 4n33.

Um sensor para a Rede e outro para o gerador (este outro auxilia na hora que a energia da rede esta fora como parametro).

Estou utilizando um Atmega328p-pu standalone. (muito bom e barato).

E para comunicação fiz uma plaquinha com MAX232. (ficou joinha)

Claro, tambem usei um conversor serial/USB.

Para tratar  o sinal dos sensores por que é analogico e oscila muito, utilizei a biblioteca Tensao.h para ler o sinal dos sensores nas portas A0 e A1.

E uma placa de 8 reles com leds sinalizadores para os testes.

Segue fotos:

Componentes na proto:

Plaquinha do Max232;

Codigo neste link:http://pastebin.com/8fnezmLm

Ultimo Codigo neste link: http://pastebin.com/Rj67MEx6 (ainda com dificuldade no contador de tempo).

Se mais alguem tiver experiencia com este assunto e puder contribuir fico agradecido.

O que mais estou me batendo é em relação ao código que na parte onde verifica o sinal se tem energia ou não ele não pode ficar acionando em falso no caso de a energia eletrica apenas piscar.

Vou seguir com os testes e conforme concluir posto mais.

Abaixo a biblioteca Tensao.h para arduino.

Um video explicando parte do funcionamento. (ainda em testes)

https://youtu.be/j881rN4xw0A

Falou galera!!!

Exibições: 3380

Anexos

Responder esta

Respostas a este tópico

Oi Carlos.

É a parte. Entendi a msg.

vou retirar os meus comentários não pertinentes.

I am Sorry

Rui

Obrigado Rui, Desculpe Carlos...rs

Amigo Rui e Sergio,

por favor, não tem que se desculpar, eu é que peço desculpas, mas somente achei que o tópico iria ficar incompreensível para muita gente aqui, desculpem vocês, minha intenção foi e é a de colaborar apenas.

Grande abraço a ambos! 

:-) entendemos. abraços.

E pessoal, alguma novidade? Como anda o projeto?

Abraços!!!

Ola amigo muito bom seu projeto executei aqui e ficou massa.Porem tenho uma duvida meio simploria pois estou adaptando este projeto a uma bomba de agua com motor a diesel pra sistemas de incedio..Mas veja a situação..Quado o motor parte o meu rele de partidas fica ainda dando partidas no motor pois nao tenho a ideia de onde viria um sinal para mandar o rele de partida parar..Tens alguma dica..?

Ola amigo muito bom seu projeto executei aqui e ficou massa.Porem tenho uma duvida meio simploria pois estou adaptando este projeto a uma bomba de agua com motor a diesel pra sistemas de incedio..Mas veja a situação..Quado o motor parte o meu rele de partidas fica ainda dando partidas no motor pois nao tenho a ideia de onde viria um sinal para mandar o rele de partida parar..Tens alguma dica..?

Amigo, que tal vc por um tempo?

Tipo, liga o rele por 5 segundos ou pelo tempo necessário para ligar o motor?

E para vc ver se o motor está ok, que tal procurar algum lugar que tenha energia após o motor estar ligado?

Talvez uma bobina enrolada no cabo de vela, consiga gerar um campo suficiente para que o arduino consiga ler...e se tiver voltagem ai, pronto, pode parar de tentar dar a partida.

Outra coisa interessante é limitar quantas partidas vc pode tentar dar, tipo ele da uma portida de 5 segundos, se não pegar, tenta de novo e mais uma...se não pegar em 3 ele não tenta mais e acende um led.

boa sorte

Boa noite. estou querendo fazer este painel, mas eu queria que quando desse queda de luz ele ja ligava o gerador e se dentro de 10 segundos a energia nao cair, ele desliga o gerador. Tem como monitorar tb atraves da web? Alguem teria todo o esquema  e lista de materiais.

Caso quiser um projeto ,tenho algo aqui preparado,exclusivo,direcionado a empresas:

gibroh_webmaster@hotmail.com

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2017   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço