boa dia galera  

estou com um projeto em arduino para um elevador já está programado,
sendo 3 botões, 1 só sobe, 1 só desce, e um sobe e desce

estou usando um motor de grua ac 220v, esse mesmo vem con um controle original,
um botão de sgurança e um botão 3 estágios, sobe, desligado e desce


arduino uno, shield de 4 reles 10A não entendo nada de arduino e nem de elétrica,
foi uma outra pessoa que fez a parte de programação, mas está correta "acredito"

meu problema é que quando retiro o controle original e passo o comando para o arduino
o motor não tem o funcionamento correto quando aperto o botão subir ele desce e as vezes sobe
e os outros botẽos a mesma coisa

gostaria de pedir ajuda de vcs se for possivel, preciso corrigir esse problema

desde já agradeço a atenção

Exibições: 681

Responder esta

Respostas a este tópico

Boa novas Fernando, voce pode fazer o seguinte mudar o codigo e fazer esse esquema ( em anexo ) , para subir acionar o RELE 1 e 2 , para descer RELE 3 e 4 , nesse esquema e so utilizar uns jumpers da chave sobe/desce para o rele, ultilize os contatos NA dos reles. se nao entender faco a modificacao do esquema e o programa,

Anexos

Ola Fernando , para facilitar ja modifiquei , esta em anexo.

Anexos

So mais uma coisa , acho melhor voce deixar o Botao de Emergencia, por medida se seguranca.

boa tarde nelson

me corrija se eu estiver erra

o que vou fazer é ligar direto da botoeira nos reles?

e só o detalhe da ligação do rele in4 com o arduino que não entendo onde ele liga, ou não liga?

obrigado

Boa tarde  Fernando, sabe o esquema e o codigo que enviei a uma hora atras e so ligar daquele jeito , pode ligar direto nos terminais do botao de sobe e desce da botoeira , ligue do jeito igual , respeitando a numeracao , se der certo voce decide tirar ou nao o botao,

so nao tire o botao de emergencia,

essa parte da ligação entendi

mas e quanto ao rele in4 ligado ao arduino?

este não se encontra ligado, essa parte não estou compreendendo bem

obrigado

Para confirmar os esquema e o codigo em anexo.

Anexos

Parte que tava faltando do esquema, em anexo.

Anexos

boa tarde Nelson

desculpa a demora, correria

bom fiz o teste e funcionou tirando alguns detalhes

algumas vezes ele subiu e desceu conforme o esperado

vc aperta botão desce/sobe ele excuta e quando vc aperta parar ele não tá parando sempre

e se apertar outro botão ele alterna o rele

desde já agradeço a atenção

Boa tarde Fernando, desculpe a demora, esqueci de mencionar que o botao de parada nao esta na funcao ( inoperante ), so tem tres funcoes , subir , descer , sobe/desce, 

para funcionar direito o circuito e o programa voce tem que colocar a chave fim de curso , se nao da erro,

ele tambem funciona so no botao sobe/desce tambem.

Isso mesmo, voce vai ter que colocar duas (2) chave de fim de curso...
no inicio e no fim

boa tarde Nelson, Mauricio

mas tem as chaves fim de curso, duas, 1 para em cima, 1 para embaixo

são elas que não estão executando as paradas

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2017   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço