Bom dia pessoal,

Baixei a biblioteca BlueVGA e fiz os testes com ela aqui na minha placa Stm32F103c8t6 (bluepill).

O problema:
Construi o circuito, conferi as conexões e as configurações de setup no Arduino IDE mas mesmo assim nenhuma imagem apareceu no meu monitor. (O monitor que estou utilizando é um FLATRON E1941).

A solução:
Entrei em contato com o autor, Rodrigo Corbera, expliquei o que estava acontecendo e ele me orientou sobre quais alterações precisavam ser feitas no código para que o sinal RGB fosse enviado através de pinos diferentes dos originais.

Fazendo as alterações que ele recomendou o meu monitor passou a exibir as imagens sem nenhum problema.

Exibições: 43

Anexos

Responder esta

Respostas a este tópico

Legal Etienne!

A biblioteca funciona originalmente gerando RGB nos pinos PC13  a PC15 com 3 bpp (bit per pixel) em 8 cores possíveis, exatamente como mostram suas fotos da tela no monitor VGA.

A alteração envia o sinal RGB para is pinos PA13 a PA15, dado que sua placa bluepill não conseguiu enviar o sinal pela Porta C. Em minha experiência isso se deve normalmente devido a existir clones do STM32F103 sendo vendidos mais barato por aí. Infelizmente isso ocorre.

Vou ver se coloco uma alteração no Github para adicionar a opção de ou usar a porta A ou C para sinal de RGB do monitor VGA.

Abraços!

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2020   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço