Eu tenho um Nodemcu Esp8266, e eu tenho um problema chato. Depois de um tempo conectado ao cloudMQTT ele para de responder aos comandos de saída (eu mudo o comando para desligar o relé e nada acontece), mas ainda recebo os dados de entrada "sensor de temperatura" no meu servidor. Geralmente, o tempo para parar de funcionar é de 30 minutos a 1 hora e retorna à operação normal após a reinicialização.

Exibições: 115

Responder esta

Respostas a este tópico

Eu não sei informar qual o regulador, só sei que é reduz de até 24v para 3.3V. Mas, creio que o problema não está na na placa base, pois antes disso eu estava alimentando o node direto pelo micro usb utilizando um carregador de celular e o problema já existia.

Boa noite, 

Muito importante informar que tipo de regulador esta usando.

Se for um regulador linear tipo LM7833 e estiver alimentando com 24V, muita energia será dissipada.

Produzindo uma quantidade expressiva de calor ! 

Existem reguladores chaveados que não esquentam. 

Aqui quando tenho desse tipo de problema seja com raspberry seja com ESP sempre a solução é a mesma: Fonte de melhor qualidade e ventoinhas.

Tenho um raspberry como videogame, sofri muito com ele. Só parou de resetar sozinho com uma ventoinha tipo cooler (80mm) e com uma fonte de 2,5A com fio integrado comprada em loja de acessorios para Raspberry. Só do fio ser mais fino já da o defeito. 

O ESP, numa escala menor, é a mesma coisa. Esquenta e precisa de muita corrente. Quando ele vai transmitir a tensão da fonte cai. Possivelmente depois de um período ele fica mais sensível pq está quente. Em limite de temperatura e de tensão. A fonte também esquenta, falha mais.

Só de vc usar um "cabo de dados" ou cabo chines em vez do cabo original de carga do celular (com fios mais grossos) já nem funciona. Dependendo do micro (esses "netbook") nem com o melhor cabo. A USB não supre a corrente.

Enfim, cercaria por esses lados primeiro antes de achar que é codigo ou coisa assim. Uma ventoinha improvisada, um multimetro na fonte, melhor se osciloscópio, pra ver se ela não está variando com o tempo. 

Como esse é um defeito que não dá pra ter a resposta na ponta da lingua vamos nos chutes. Esse foi o meu, que é muito similar ao do colega Carlos kwiek, que provavelmente já passou pelos mesmos problemas.

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2018   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço