Olá, sou iniciante mais estou bastante interessado no Nodemcu 8266. Estou tentando copiar um exemplo que verifiquei onde o mesmo acendia e apagava lampadas via browser ou celular. A configuração do ide do arduino para trabalhar com o Nodemcu OK, acesso via browser e celular a pagina html OK.

Só que notei que quando finalizei a montagem do esquema meu modulo relé não deu sinal de vida. Abaixo segue dados:

Dados:

Ligação feita seguinte:

Relé / ESP12

vcc = pin 3,3v

in1 = vin

gnd = gnd

Entrada = Fase

NA = conecto lâmpada

Desta maneira meu modulo relé não aciona ou acende seu próprio led. 

Exibições: 2879

Responder esta

Respostas a este tópico

Oi VS, boa noite.

Uma recomendação.

Remova o seu sketch da área de texto e anexe-o como arquivos.

Leia:

http://labdegaragem.com/forum/topics/sugest-o-de-como-postar

Outra coisa, voce deixou esposta sua rede  Seu  SSID e sua Senha.

Rui

Desculpe o equivoco, já corrigi e vlw o toque do ssid.

Olá Victor tudo bem?

Nunca cole o seu code na área de texto, isto deixa a formatação horrível de interpretar. Siga as instruções de como postar seguindo esse link  http://labdegaragem.com/forum/topics/sugest-o-de-como-postar 

Espero que entenda que essas regras são para melhor organização do site.

"Ligação feita seguinte:

Relé / ESP12

vcc = pin 3,3v

in1 = vin

gnd = gnd

Entrada = Fase

NA = conecto lâmpada"

Provavelmente seu módulo está ligado errado. O vcc do relé tem que ser ligado em 5v(se estiver usando nodemcu ligado no usb, use o pino Vin) e o pino "in1" do relé tem que ser ligado no pino "D2" do nodemcu, segundo o code.

corrigindo, o correto seria ligar assim:

Ligação feita seguinte:

Relé / ESP12

vcc = pin Vin

in1 = D2

gnd = gnd

Entrada = Fase

NA = conecto lâmpada

Tenta lá, meu amigo, e poste os resultados(não esqueça de editar seu tópico).

Olá amigo obrigado pelo toque, segui como orientação e lê o tópico de como postar. Mas segui conforme orientado fiz as modificações, mas sem sucesso.

Vcc = pin Vin
in1 = D2

Faça como nosso amigo Gustavo falou, verifique se o modulo relé está funcionando.

Com essas modificações pelo menos o led dele acendeu?

Verificado,e sim estão funcionando o módulo relé. Estava lendo aqui e vi que o módulo relé necessita de 5v para funcionar, e o esp somente fornece 3v e o pino vin aceita 5v para sua alimentação.

A ideia seria alimentar o alimentar a placa esp e o módulo relé com 5v externo? Se sim alguma dica de como proceder melhor maneira?

Link do fórum onde tem a possível solução

http://labdegaragem.com/forum/topics/duvida-rele-16ch-e-esp8266

Vou testar!

Como eu disse acima, se você estiver utilizando a placa nodeMcu como você descreveu, o pino Vin da placa nodeMCU fornece os 5v necessárioas para o módulo desde que esteja ligada no usb do computador. Não confunda o pino Vin com o pino 3,3. Nesse link que você postou tem vários desenhos e está muito bem explicado.

Nesse momento tenho um sensor de rotação ligado no meu nodemcu que nescessita de 5v e está ligado como eu te falei e funcionando normal. 

O pino vin aceita 5v para sua alimentação, mas se vc alimentar o nodemcu pelo usb o pino vin vai fornecer 5v. Pode ligar pois DEVE funcionar.

Olá amigo desculpa a demora, mas vamos lá.
Como me orientou segui, porém não funcionou. segue abaixo

1- ubs/notbook - Esp
vcc - Vin
gnd- gnd
D2 - in1

2- Carregador 5v - Esp
vcc - Vin
gnd- gnd
D2 - in1

P.S - Testei tensão nos pinos Vin + Gnd e o mesmo dando 0,3 continuo. Irei postar fotos da ligação que estou fazendo.

Caro colega obrigado pela força. Teste o modulo relé e sim estão funcionando.

O ultimo link tras uma discursão no forum muito interessante, onde explica que necessário 5v para o modulo relé, e o mesmo pode ser alimentado de fonte externa pelo pino vin e gnd.

A dúvida seria a melhor maneira de fazer, pensei naquelas fontes de carregador, jumpear e alimentar o vin e gnd.

Pode usar um carregador de celular ( 5V) . 

Suba uma foto do seu modulo, mesmo que alimente o ESP na entrada VIN e GND com 5V as saidas GPIO continuaram tendo 3.3V na saida, poste a foto do seu modulo rele ou um link onde comprou que tenha fotos.

Veja videos no meu canal Clique AQUI

Abs.

CK

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2020   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço