Alguém já trabalhou com esse shild? Quero liga-lo ao Arduino. Porém não tive sucesso. Algum tutorial para me indicar?

Exibições: 429

Responder esta

Respostas a este tópico

Stella,

Segue desenho para esclarecer suas duvidas.

Aaah ta nossa buguei aqui ! kkkk 

Acho que entendi.. No passo 2 vou escolher os Pinos 0 e 1 se for usar a Serial, e se for usar a SoftwareSerial escolho os pinos  7 e 8. E no passo 3 aciono a chave para o lado de fora. 

Agora o passo 7 ainda não sei como fazer. =/ 

Stella,

No shield existe ( próximo do pino 9 ) um jump ( JP 01 ) que está livre. Caso for utilizar reset por software, deve-se soldar esse jump na placa.

O reset do modulo SIM 900 é feito quando é aplicado um sinal alto por alguns segundos e retornado para nível baixo.

void powerUpOrDown() {
pinMode(9, OUTPUT);
digitalWrite(9,LOW);
delay(1000);
digitalWrite(9,HIGH);
delay(2000);
digitalWrite(9,LOW);
delay(3000);

}

Sds,

Stella boa noite , 

Envie por favor o link do seu módulo. 

Use uma fonte com 2A aproximadamente. Esses módulos consomem muita energia. 

Não sei se o seu módulo é esse, mas veja essa mensagem :

Because SIM900 peak current more than 2A. This shield must work with a external DC9V power supply.

Existem vários topicos de colegas do Lab, sobre o módulo SIM900 (sugiro que estude-os) 

http://labdegaragem.com/forum/topics/arduino-php-sim900

http://labdegaragem.com/forum/topics/help-sim900-sms

http://labdegaragem.com/profiles/blog/show?id=6223006%3ABlogPost%3A...

http://labdegaragem.com/forum/topics/anatel-come-a-a-mapear-celular...

É muito importante que informe o modelo do seu SIM900 - shield, pois podem existir  algumas variações dependendo do fabricante.

O seu modelo é esse ? 

http://kumantech.com/kuman-simcom-gsm-gprs-quad-band-modules-2g-dev...

Veja se essa documentação se aplica ao seu modelo:

http://www.geeetech.com/wiki/index.php/Arduino_GPRS_Shield

Sim isso! Exatamente esse.

http://produto.mercadolivre.com.br/MLB-707887314-arduino-modulo-gsm...

Esse é o link que comprei.

Sou nova por aqui, me inscrevi essa semana. Ainda estou meio perdida. Obrigada pelas dicas.
Vou estuda-los sim.
Pessoal esta sendo muito solicito.
Vou estudar tudo que me passaram aqui.
E assim que funcionar, posto o resultado. :)

Funcionou? Conseguiu ligar logicamente o módulo? Estou com o mesmo problema e a minha placa é igual a sua.

Caio, seguiu as orientações dos colegas ?

Mande foto da sua montagem e o link que seguiu para fazer a montagem. 

Esta usando fonte com 2A ?

Qual problema esta ocorrendo ? Mande telas.

Segui tudo. Mas, definitivamente esta placa que Stella Marques e eu possuímos é muito diferente. Não consegui fazer a mesma ligar programaticamente usando as recomendações. A forma que encontrei foi criar um jumper no próprio botão liga/desliga. Pensei em por um transistor e mandar sinal alto por 2 segundos, mas descobri que não faz diferença deixar o sinal como alto para sempre... então foi o que fiz.

Caio ainda quer ajuda ?

Mande todas as informações da sua montagem . 

Fotos, links do seus módulos, sketches, Tutorial que foi usado, etc

A solução foi fazer um jumper usando barramentos, fios e tubos termo retráteis. Quando o jumper estiver conectado, ele "bypassa" (sobrepõe) o botão. Ou seja, o botão fica num eterno estado de "clicado" (sinal alto). O sistema entende isso como uma "flag" que marca ligado.
Prontinho! Nem precisa de código.
Porém, neste caso, a placa nunca desliga. Recomendo, caso necessário desligar a placa, que use um transistor NPN no lugar do jumper para controlar o status de ligado/ desligado. Neste caso, use o código para controlar:

void powerUpOrDown() {
pinMode(9, OUTPUT);
digitalWrite(9,LOW);
delay(1000);
digitalWrite(9,HIGH);
delay(2000);
digitalWrite(9,LOW);
delay(3000);

}

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2017   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço