Boa noite,

estava acompanhando uns tutoriais na internet de como configurar uma tela nextion para arduino. Baixei a biblioteca e montei o programa conforme as explicações, mas creio que desde que o vídeo foi feito (2017) ate hoje as bibliotecas sofreram mudanças em seus comandos e os mostrados já não servem mais.

Estava verificando as bibliotecas, os arquivos .h e .cpp mas não consegui distinguir onde encontro os comandos referentes as funções que necessito. Alguém saberia explicar uma forma de localizar os comandos? 

seria algo assim inicialmente


NexProgressBar j0 = NexProgressBar(0, 3, "j0");  //barra de progresso
NexText LeituraAnalogica1 = NexText(0, 1, "t1");  //escrever o valor da analogica na caixa de texto
NexDSButton bt0 = NexDSButton(0, 4, "bt0"):     // um botao de dupla funcao on, off 

Exibições: 197

Responder esta

Respostas a este tópico

Boa noite J2C,

Qual o link do tutorial?

qual biblioteca vc baixou?

Anexa um arquivo com o seu código, fazendo assim:

e procure o arquivo no se PC.

Assim ficará mais fácil ajuda-lo.

RV

Boa noite J2C,

com as informações que vc postou ajudou bastante encontrar algumas causas dos erros

ao compilar.

1. Esta biblioteca que vc postou não é a correta para este projeto.

2. Existem diversos erros  no seu código:

   erros de digitação, falta de definição de ports, falta de definição de variáveis,

   troca de nome de variáveis, e outros mais.

O correto é vc baixar os arquivos indicados no link do youtube onde está escrito

       Arquivos para download: Opção 1  ou Opção 2.

No arquivo .rar contém a biblioteca correta e uma copia do código usado no video,

que é muito similar  ao seu (acho que vc pegou o código do video e modificou. correto?) 

Vc pega a copia da biblioteca que está dentro do rar  e instala na sua IDE do Arduíno.

     ITEADLIB_Arduino_Nextion-master.zip

Ao instalar aqui deu um erro de duplicidade de um arquivo, e eu cliquei em ignorar.

Dai vc compila o código mostrado no video que acompanha o rar.

      nextion_arduino_wr_source_188.ino

Mas aí qdo eu compilei deu um erro, dizendo que faltava a serial2.

Achei estranho  depois de analisar os arquivos .h. chequei a conclusão que esta biblioteca

só funciona para Atmega2560  (atmega)

Ai, mudei a definição para atemga e compilou corretamente.

Se vc conseguir também compilar corretamente,

meu conselho é fazer uma cópia do código e ir alterando a  cópia  conforme sua necessidade.

RV

P.S.

Depois de publicar o post, pesquisei no  GitHub e encontrei o seguinte:

Configuration

In configuration file NexConfig.h, you can find two macros below:

  • dbSerial: Debug Serial (baudrate:9600), needed by beginners for debug your nextion applications or sketches. If your complete your work, it will be a wise choice to disable Debug Serial.

  • nexSerial: Nextion Serial, the bridge of Nextion and your mainboard.

Note: the default configuration is for MEGA2560.

Redirect dbSerial and nexSerial

If you want to change the default serial to debug or communicate with Nextion , you need to modify the line in configuration file:

#define dbSerial Serial    ---> #define dbSerial Serialxxx 
#define nexSerial Serial2 ---> #define nexSerial Serialxxx

Depois fui no arquivo NexConfig.h e alterei a linha 37 para ficar
assim:
#define nexSerial Serial
dai compilpou como UNO.
RV

Obrigado pela ajuda Mineirin RV. Em arduino eu sou curioso, e como tal, me meto a fazer experiências que como pode ver nem sempre dão certo. Mas tudo é aprendizagem no final das contas, sobre os pontos que mencionou:

1. Esta biblioteca que vc postou não é a correta para este projeto.

Realmente pensei que seria uma biblioteca padrão, não vi que havia uma especifica no vídeo, obrigado pela informação.

2. Existem diversos erros  no seu código:

Com certeza, nunca usei estas telas e estava vendo o vídeo e montando o código (similar) pois estava já inicialmente adequando ao meu código pessoal. Fazendo testes, mas quando vi que havia problemas com as livrarias pensei que poderia ser algo referente a atualização das mesmas. Mas não é o caso, há uma específica para o caso em questão.

Vou buscar a livraria no link bem como o exemplo do código para experiencias iniciais, quanto ao modelo de arduino ser o ATmega, não tem problema eu já usava um atmega para as simulações pois meu programa tem muito mais entradas e saídas, um UNO não comportaria. 

Como o Minerim falou, essa biblioteca foi feita para o Arduino Mega.

Nesse tutorial, na parte de Bibliotecas esse cara ensina como alterar o arquivo pra funcionar no uno:

https://www.fernandok.com/2018/05/display-nextion-com-arduino-uno.html

Conforme descrevi no post , para usar no UNO,

basta alterar a linha 37 do arquivo NexConfig.h para ficar assim: 

#define nexSerial Serial

RV

Obrigado pela ajuda pessoal, mas estou usando mesmo um mega 2560, mas aparentemente o compilador nextion (para simular a tela) e o arduino não estão conversando. Usei a tela original e o programa original disponibilizados no vídeo e nada.

Percebi que se deixar o compilador nextion uns minutos ele trava, como se tivesse tentando comunicar sem conseguir, outro detalhe é que aparece uma linha em vermelho, buffer overflow.

Também percebo que as duas janelas do simulador e do MCU não estão funcionando conforme o vídeo, apenas a janela do simulador repete sempre o mesmo código, 24 FF FF FF, suponho que seja retornando FALSE para a comunicação.

segue print do compilador:

compilador.jpg

OBS: no print como não funciona com a tela original, já estava tentando refazer para mais testes por isso não é a mesma tela.

Olá boa noite!
JC, você está usando uma fonte externa para o nextion?

Estou apenas usando o arduíno mega e o simulador da própria nextion, incorporado ao editor de telas. Não estou com uma tela de verdade. Sendo assim estou alimentando ele pela USB onde comunica com o meu PC.

Entendi. O Nextion não entra na jogada. Quando entrar precisará de uma fonte externa.

Tente então variar o BAUD RATE do Arduino Mega.

O padrão é 9600. Tente colocar outros valores como 115200

Não sei como está seu código, mas verifique se vc está usando a Serial2 do Arduino Mega para comunicação pois, nesse caso, não vai funcionar a serial USB que são outros pinos. Para usar a USB deve usar a Serial padrão que são os pinos 0 e 1.

Tente fazer as modificações que foram sugeridas anteriormente no arquivo de configuração. 

Certo, ja estão feitas, e tive melhoras, já não trava mais e tenho respostas no quadro do MCU, RX e TX estão operantes, mas surgiu um novo erro: Invalid Parameters, no compilador Nextion. 

Estamos chegando em la, mas ainda falta algo, caso tenham mais alguma ideia por favor fiquem a vontade testarei quando voltar.

JC, a mensagem completa é só essa?

Não está indicando qual componente está com erro?

Quando o compilador acusa um erro, pode ser em qualquer ponto do projeto e, normalmente, ele indica.

Envie a msg completa do erro.

Se estava funcionando e começou a dar erro, deve ser nas última alterações q foram feitas no projeto.

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2020   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço