LED Rx sempre ligado e não consigo mais gravar nenhum programa no Arduino

Olá pessoal, o Led RX está sempre ligado e não consigo mais gravar nada no arduino. O que faço? 

Obrigado.

Exibições: 154

Responder esta

Respostas a este tópico

Bom dia VA.

Qual é o arduino?

Original ou xingling?

Qual o chip de entrada da USB?

RV

Bom dia! Arduino uno, xingling, e o chip é um CH341SER.

Para tentar usar o Blink como o colega sugeriu basta usar o que vem embutido na IDE Arduino clicando em exemplos e escolha Blink.

O mais provável é que tenha danificado o o CI que faz a comunicação serial, poderia tentar usar uma placa FTDI (Se tiver um) caso não pelo custo beneficio é melhor comprar uma placa nova que baixaram muito seu preço.

Abs.

CK

Bom dia!

O Led RX (taxa de recepção) liga quando você está enviando algum código para o Arduino, mas se apaga quando está transmissão acaba. Já tive um problema desse, com Arduinos paralelos. A recepção dele foi danificada. Para confirmar isso, e ter certeza que não é apenas um problema no circuito do LED por exemplo, mande um programa BLINK para seu Arduino. Vá na internet e procure um. É um programa dos mais simples possível, como o "PISCA LED". Se conseguir enviar corretamente, o Arduino ainda está funcionando. Caso contrário, já era mesmo.

Espero ter ajudado.

Provavelmente deu pau na interface serial. Mas ainda assim dá pra usar, você pode:

1 - Colocar o microcontrolador em outra placa só para gravar os sketches.

2 - Utilizar a técnica in chip programming (https://www.instructables.com/id/Program-ATtiny-Chips-with-Arduino/)

Portanto não se preocupe, se não precisar utilizar a porta serial (do hardware) para debug dá pra usar a placa tranquilamente.

Boa tarde VA,

se você observar no esquema neste link: 

https://arduino.stackexchange.com/questions/36463/differences-betwe...

verá que o LED RX está ligado um lado em um resitor, que por sua vez está ligado em + 5V.

O outro lado do LED está ligado direto no port D1 do atmega328 e no conetor D1 do board.

Também está ligado via resistor de 1K ao pino 3 (RXD) do CH340. (Acho que é 4 no CH341).

Desta forma qualquer ponto deste que vá para o nível de Gnd provocará o acendimento do LED.

Para fazer uma correta determinação de problema, faça assim:

Remova o atmega328 e ligue o board.

Se o LED não acender, pode ser o atmega328 com problema, ou com um cod que usa port1 em LOW.

Tente também ver se consegue identificar um possível curto circuito do Port D1 para Gnd.

Se nada disso resolver, provavelmente seu CH341 está danificado, dai ou usa um conversor USB/TTL,

ou adquire outro board.

RV

Boa noite, 

Você tem estação de solda para componentes SMD ? 

Se não tiver, compre um outro Arduino. 

Deve ter queimado o chip  CH341SER.

Pessoal, irei verificar tudo que falaram. Muito obrigado mesmo
Grande abraço!

Se for um duemilanove é fácil, basta aquecer os terminais até soltar o integrado.

Daí vc precisará de um conversor USB/Serial para fazer o upload dos sketches.

Infelizmente não é um duemilanove. Mas obrigado!

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2018   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço