Boa tarde senhores, estou fazendo um gerador eólico e estou desenvolvendo os sensores necessarios, que tratam - se do Anemometro e da Biruta.

O Anemometro é responsavel por determinar a velocidade do vento, já a Biruta é responsavel por determinar a direção do vento.

Eu confeccionei o circuito da biruta com 8 reed switchs distribuidos num disco circular de acordo com os pontos cardeais primarios e secundarios, que são acionados por um imã que está colado numa haste localizada acima do circuito, onde a mesma é orientada pelo vento.

Tambem confeccionei o circuito do anemometro com 3 leds emissores e 3 leds receptores (fototransistor), que estão de frente um com o outro.
O led trabalha sempre aceso, de modo que para gerar pulso, basta interromper a emissão da luz do led para com o recpetor, para isso, eu fixei 3 hastes com copinhos na ponta que giram sobre um eixo móvel de acordo com a velocidade do vento, e nessas hastes colei uma lixa na vertical, onde durante o giro ela passa exatamente entre o led e o led receptor, interrompendo a passagem de luz gerando pulso, a frequencia com que esses pulsos sao gerados determina a velocidade do vento.

Este projeto trata se do meu trabalho de conclusao de curso e ficarei muito grato pelas dicas e melhorias que voces puderem me ajudar, sou péssimo com programação, toda e qualquer ajuda é muito bem vinda, desde já agradeço a atenção de todos voces.

Obs: um dos membros ja tem me ajudado bastante, espero que esse topico tambem ajude outros que possuem as mesmas dificuldades que eu.

segue em anexo os skecths referente ao anemometro e referente a Biruta+motor de passo

preciso mesclar essas duas programações numa só, para poderem rodar juntas.

Exibições: 518

Anexos

Responder esta

Respostas a este tópico

Muito obrigado pela ajuda José!

Voce acha que posso fazer uma "gambiarra" no circuito para realizar essa alteração ?

Se eu tivesse mais tempo faria um novo circuito, mas faltando um mes para apresentar estou com a corda no pescoço..

acho que dá sim. 

José andei analisando o circuito que voce me passou, e me desculpe a ignorancia, mas notei que "aparentemente" a saida dos dois sensores também vai para o GND, do mesmo modo que o meu circuito..

essa afirmação esta correta? ou me equivoquei ?

novamente muito obrigado

Renan, vejo que tem dificuldade em entender esse circuito . 

Explicando:

Dois sensores ? Não, um é o led que emite a luz infravermelha, e o outro é o sensor de infravermelho, que no caso é um fototransistor. 

O terra desse circuito deve ser conectado no terra do Arduino. 

O coletor do fototransistor (que é a unica saída) deve ser conectado em das portas analógicas do Arduino. (talvez possa conectar em porta digital, dependendo da quantidade de luz). 

entendo, acredito que a unica alteração que terei que fazer, é referente ao aterramento no arduino e o incremento de um resistor de 10k, pq o desenho das trilhas está exatamente igual ao desse circuito que voce me passou. Em, anexo foto da analise para retificar no circuito..

Anexos

ah e claro, ligar uma porta logica na saida do fototransistor

Sugestão - retire esse fio de jumper e instale um resistor, não ? 

Naõ se esqueça de conectar os fios das saídas. 

Vai usar uma porta para cada sensor ? Ou vai uni-las em uma porta somente ?

Grande sacada José, vou colocar o resistor no lugar do jumper!

isso, vou soldar 1 fio em cada saida do fototransistor ..

Entao Jose, inicialmente a ideia era uma porta para cada sensor, mas o amigo Mineirin RV me indicou usar uma porta só, não sei o que isso pode alterar na minha programação.. nao entendi muito bem essa parte de usar apenas uma porta.. preciso pesquisar mais

mais uma vez muito obrigado José!

Mais uma coisinha, onde devo ligar o negativo da minha fonte de alimentação?

pois o positivo vai naquele primeira trilha mesmo, mas e o negativo ?

Renan , se a fonte for de 5V , conecte o positivo no +Vcc e o negativo no Terra (GND). 

Não se esqueça de conectar o terra do Arduino com o terra do seu circuito. 

sim a fonte é de 5V..

No terra do circuito eu coloco o negativo da fonte, e nesse mesmo terra do circuito eu ligo no ?GND do arduino, é isso ?

mais uma vez obrigado José pela paciencia

Sim Renan , que Deus lhe ajude ! KKKK

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2017   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço