boa noite pessoal,

estou caminhando nesse maravilhoso mundo da  programação e aprendendo novas funções, porem me deparei com uma dificuldade, e gostaria de ajuda de voces.

estou acionando 3 botoes, quando eu aperto o  1 e 2 chamo a função void led1() e quando pressiono o botao 2 e 3 chamo a função void led2(), com delay funciona sem problemas, mas se eu chamar uma função, não consigo usar a outra por causa do intervalo do delay, gostaria de adaptar para millis, porem nos meus testes com millis, a função ta se comportando como botao de retenção, gostaria da ajuda de voces.

obrigado

https://pastebin.com/xFku0RmN

Exibições: 220

Responder esta

Respostas a este tópico

Olha um artigo que escrevi que pode te ajudar:

http://www.labirito.com/tutorial/arduino/multitarefa

Boa sorte,

  'Eiju

boa noite,

desculpe a demora ao responder, estava meio corrido esses dias, 

li seu texto, explica muito bem, porem ainda estou com a mente um pouco travada, não conseguindo assimilar algumas funções, mas acredito que seja com o tempo, irei melhorando isso.

são 3 técnicas, vou testar as 3 para meu melhor entendimento,

obrigado

Olha um artigo que escrevi que pode te ajudar:

http://www.labirito.com/tutorial/arduino/multitarefa

Boa sorte,

  'Eiju

Bom dia V,

o C.E.L.S.O. está correto na sua colocação.

A sugestão dele indica um uso mais técnico dos recursos.

Mas também pode testar esta modificação que efetuei no seu code, e depois contar pra gente

o resultado. 

RV

Anexos

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2019   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço