Bom dia pessoal,

Peguei um Ethernet Shield 5100, fiz o UpLoad de um programa Webserver para o Arduino e nada de conseguir comunicar, daí fiz o seguinte:

- Testei o exemplo DhcpAddressPrinter porém deu o erro: 

   Failed to configure Ethernet using DHCP

-Peguei o cabo de rede e espetei no computador, que pegou IP normalmente

 

Daí tive a ideia de configurar manualmente o IP e o MAC no roteador, porém me surgiu a seguinte dúvida:

Como configurar o MAC  0xDE, 0xAD, 0xBE, 0xEF, 0xFE, 0xED no roteador, se na interface de configuração o padrão é 00-88-14-4D-4C-FB ?

Se alguém puder me ajudar, desde já agradeço.

Exibições: 4189

Responder esta

Respostas a este tópico

Boa tarde Luiz,

Eu recomendo que você abra um topico, descreva seu problema, e não use um topico resolvido, estes topicos servem apenas como referencia, mas se reabrir, sua mensagem ficara perdida aqui geralmente.

Sua pergunta é muito pontual, quando abrir seu topico, descreva o que esta fazendo, como esta ligando e que codigo esta usando, desta forma ira obter respostas para seu problema.

Abs.

CK 

Ok.

Muito obrigado Carlos.

Mas hj, graças a Deus consegui jogar as informações para a web via acesso interno.

Realmente, estava utilizando uma conexão totalmente diferente da que alimenta o Arduino.

Mais uma vez, muito obrigado pela dica.

Boa tarde. 

Boa tarde Luiz

Por nada Luiz, disponha fico feliz que tenha resolvido.

No meu canal encontrara algumas dicas legais, abaixo o link.

CANAL AQUI

Meu blog aqui no LDG BLOG AQUI

Bom domingo!

Abs.

CK

Olá Nilton,

Fiz este vídeo com algumas dicas, espero possa ajuda-lo.

http://labdegaragem.com/forum/topics/ethernet-shield-conectar-rede-...

Boa sorte.

Abs,

Carlos, parabéns pelo vídeo! Muito didático!

Gente, descobri que ontem (quando fiz o teste rapidamente pela primeira vez com o outro roteador), o cabo de conexão com a internet estava com mal contato e as políticas de rede definidas pelo provedor não bloqueavam o acesso ao serviço webserver, logo, era uma rede interna e dava tudo certinho. Porém, com a internet funcionando, data erro de time out, não abria de jeito nenhum.

Então abri um chamado para a empresa fornecedora de internet local e o administrador da rede agora à tarde liberarou no firewall. No caso é um provedor de internet local, aqui num município interiorano à 250km de Fortaleza-Ce. 

Obrigado mais uma vez a todos pelo apoio e atenção neste tópico.

Com ele vimos que não existe restrição de comunicação entre ethernet shield e o modem/roteador e que políticas de rede podem interferir na execução do WebServer/Aplicativo.

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2020   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço