Boa noite amigos gostaria de uma ajuda , entendo muito pouco de html , alguém poderia me ajudar com esse código , incluir mais um botão por favor..segue o código em anexo...

Exibições: 254

Anexos

Responder esta

Respostas a este tópico

Posso fazer isso para você assim que chegar em casa,  mas de uma olhada neste vídeo do meu canal, quem sabe lhe interesse.

CLIQUE AQUI

Abs.

CK

Boa noite Carlos kwiek obrigada pela resposta , mais uma pergunta  meu esp8266 01  fica caindo a conexão ,cada  duas hrs cai , so tirando da tomada e colocando volta ,vc sabe como resolver isso por favor ...

achei que fosse minha internet , mais nao e , poque meu nodemcu  esp8266 nao cai ...

Boa noite Marcela,

Existem vários motivos para p ESP8266 cair, se esta descartada que não é sua internet, poderia ser sua fonte de alimentação,  que fonte você esta usando para alimentar e de que forma, pela entrada VIN ?

Também poderia ser falsos contatos se estiver usando jumpers e protoboard e alimentado o ESP através da proto voa jumpers, como disse são diversos os motivos, se esta caindo exatamente cada 2 horas, poderia ser o sleep mode ativado (modo de baixo consumo se não tem atividade por x horas.

Em fim, é difícil determinar, mas tem que ir analisando, se puder diga como esta alimentado, se tiver desenho ou algo do tipo sempre é bem vindo.

Abs.

CK

Bom dia Marcela,

Anexo o seu código modificado agora com dois botoes. no formato ,ino.

Anexo um código igual, mas com a diferença que você não precisa colocar nenhum IP, o roteador atribui a ele um IP, e este IP é impresso no seu monitor serial, este sera o IP que você colocara no navegador, mais o numero da porta

.Esta em formato txt. assim você copia e cola na sua IDE e da o nome que quiser.

Comentei o melhor que pude, e fiz este código diferente também, já que entendo que seu proposito é estudar, por isso tratei de ser o mais didático, se tiver duvidas ou algum problema poste aqui.

Bons estudos!

Abs.

CK.

Anexos

obrigada pelas as dicas e por ter alterado os botoes  Carlos kwiek , consegui entender onde alterar , bem comentado entendi perfeitamente , esse foto e bem parecida como meu esp8266 01 esta conectado , sera que tenho que mudar alguma coisa para instabilizar a conexao  para parar de cair?

 Carlos kwiek estou usando esse Código segue em anexo.... 

Anexos

Marcela boa noite,

O código esta ok pelo visto, eu quase não uso mais o ESP-01, mas se o faço é usando barramento I2C por exemplo.

Link no meu Github sobre um tutorial meu sobre isso AQUI la tem o link do vídeo também.

Abs.

CK

Marcela boa noite,

Por nada, disponha sempre que precisar.

Eu fiz um PDF com algumas recomendações, todas elas visando estabilizar o funcionamento do ESP-01 pelas experiencias que eu como tantos outros colegas aqui tivemos, não vou citar nomes para não cometer o erro de esquecer de algum, e inclusive muitos deles podem opinar no seu tópico com o mesmo proposito que o meu, já que  ideia é sempre compartilhar conhecimento.

Trate de implementar o que for possível das recomendações e veja se com as implementações melhora, eu creio que sim.

Abs. 

CK

Anexos

Boa noite  Carlos kwiek obrigada por me ajuda , depois das sua informações de HTML , consegui da uma mudada no código para eu usar no nodemcu  com 8 reles ,coloquei 8 botoes , cada um botão para ligar e desligar ,  por ai tudo bem, tudo perfeito ,mais vem o problema ,a pagina do web fica no máximo uns 5 minutos conectada e depois cai a pagina , só reiniciando o nodemcu para volta , tem como resolver essa queda da pagina web? segue o código em anexo

Anexos

troquei a biblioteca server por essa e rosolveu o problema de cai a conexão 

#include <ESP8266WebServer.h>

Bom saber Marcela, mais uma contribuição sua para o forum.

Parabéns!

Abs.

CK

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2018   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço