ESP 32 como webserver não funciona sem estar ligado no PC

Carreguei no esp 32 um sketch dos exemplos (webserver).

Como era de esperar funcionou perfeitamente.

Quando liguei usando um adaptador usb para tomada não funcionou.

Onde acho literatura sobre isso ou é burrice mesmo? 

Exibições: 67

Responder esta

Respostas a este tópico

Olá. 

  Vc não disse o modelo, a corrente da fonte, o tipo de cabo, nada, mas.. Vejo 3 possibilidades:

  1)  A comunicação entre o ESP32 e o integrado USB/Serial se faz por 4 fios. Um deles é o reset. Pode ser que no modelo que vc tem em mãos o integrado USB/serial não mande um nivel que permita o funcionamento do ESP se ele não estiver devidamente ligado. Verifique o pino EN (terceiro na esquerda). Compare a tensão desse pino com o esp no PC e com o ESP na "tomada".

  2) Veja com o multimetro quantos volts sua fonte entrega realmente. É preciso 5.0 ou até 5.1. Fontes padrão camelô raramente fornecem isso. 

  3) É preciso que seu cabo seja do tipo "carga rápida" ou um cabo bom, que veio com um aparelho. Cabos ruins prejudicam o funcionamento pq o consumo do módulo é grande.

  Isso ocorre principalmente pq o esp consome em picos de corrente quando transmite. O celular também... mas ele tem uma bateria para fornecer a corrente nos picos. O ESP precisa que a fonte forneça.

 

Obrigado Eduardo e desculpe tê-lo incomodado.

O problema era  na qualidade do adaptador.

Usei o do celular Samsung e o da LG e deu tudo certo .

Muito obrigado. 

 

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2020   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço