Boa noite pessoal, alguém já utilizou o módulo SIM900a mini v3.8.2 ? consigo comunicar com ele via comando AT, porém ao tentar enviar um SMS utilizando o comando abaixo, sempre retorna erro, e o Led D6 do modulo fica piscando. qualquer ajuda é bem vinda.

AT

OK
AT+CMGF=1
OK
AT+CSCS="GSM"
OK
AT+CMGS="+5531XXXXXXXXX"
> TESTE
ERROR

Exibições: 3413

Responder esta

Respostas a este tópico

Alci depois que aparece esta mensagem é que se liga o módulo, se ligar ele antes não irá funcionar

Alvaro, quando estava atualizando o seu modulo fez uso de jumper/s no formato de "X" ?

Não usei jumpers. Somente a ligação do Tx e Rx e Gnd. O que Houve ?

O Load do firmware não completa.

Acredito que o motivo deva ser esse.

Preciso de um FT232 pois o meu arduino usa o controlador USB da primeira foto.

Eu utilizei este que o chip é soltado na placa. Não consigo ler o que está escrito nos chips que vc mencionou. Tive que comprar o conversor USB TO TTL (vermelho) pois esse foi o que eu vi num vídeo que deu certo na atualização do Firmware e os que eu tinha não estavam funcionando (dava erro)

Lembra qual era o erro ?

Alcir, parecido com o seu.

Colega ,boa noite estou com um problema igual ao seu,meu sim900a não funciona .Já atualizei o umas quinze vezes,
todas com êxito,mesmo assim não funciona.Só consegui atualizar com Baud=57600bps .
Os firmware que voltou a funcionar (a maior parte não funcionou ,só piscava como um alerta) os que tinha as letras "M32."

Rogerio, como assim atualizo o firmware e não funciono.

Explica isso ai 

Como você está ligando ele ao arduino ?

Acho que vc vai ter que instalar o driver deste adaptador dependendo da sua versão do windows

Comprei um Adaptador Usb Ttl Serial Pl2303, vou testa hoje fiquem online

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2018   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço