Boa tarde!

Estou em um projeto de automação onde via web, posso acender e apagar lampadas e ou quaisquer dispositivos!

Pela web eu vejo se está ligado ou desligado, mas quando entro com a chave paralela não consigo fazer a inversão do código quando o botão manual é acionado!

Exemplo 

1 botão manual desligado, na web iniciando com tudo off. status na tela apagado! Quando clico no botão da web, acende a lampada e aparece ligada!

2 Botão manual ligado, na web com tudo off, aparece status na tela ligado, mas nesse caso eu preciso fazer com que o botão liga desligue e o desliga ligar!

Não sei mais o que fazer!

Alguém pode me ajudar?

vilque@vcj.com.br

Exibições: 689

Responder esta

Respostas a este tópico

Assim p mim não rola, tem que colocar interruptor paralelo, e se der pau no arduino, funciona normalmente! entendeu?

rui para sabe o estado da lampada pois o rele pode est acionado mais  vc desliga no apagado ai  sem o sensor cotinuara como se a lampada estivece ligada .....

Isso. Não vi outra maneira a não ser interruptor pulsando, mas ai se der uma pane vou ficar sem acender a luz.

na minha casa ja fisso tudo planejado  os fio sai dos interupitor e vao cara  um painel  onde tem uma shild com 16 reles depois postarei mais detales

Pode informar seu e-mail ou Whats? o meu é vilque@gmail.com  e whats 11 9 75753535.
Só não consegui ainda resolver o problema da inversão do código quando aciono o botão físico, que inverte o botão na web...... Tá osso isso!!! Hehehehehe...

Olhe meus quadros (um só para 12v e automação) como estão, com quase toda iluminação em 12v e baterias de no-break para segurar tudo ligado quando acaba a luz! Aguenta por volta de 5 dias!

Anexos

acabei tendo que modifica o meu cadro pois e muita placa e nao inha cabe no  meu quadro

fico tope seu quadro

Oi TAS, bom dia.

acabei tendo que modifica o meu cadro pois e muita placa e nao inha cabe no  meu quadro

"  

???????

Rui

e por que

dj-naldo@hotmail.com

vc ja desenvolveu a sua enterface web?

Bom dia Vilque! eu também já estive com o mesmo problema que você! mas eu encontrei uma solução simples.

com isso você poderá utilizar tanto o interruptor físico, quanto os botoes virtuais, e o estado dos botoes não serão representados pela saída digital mas sim por uma entrada digital... 

veja só como ficou a instalação:

Anexos

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2017   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço