[Resolvido] Ao ligar o ESP8266 parte de casa fica sem internet

Estou com um problema com o ESP8266, o código está anexado, mas não é nada complexo, tem 30 linhas, só ligo o servidor e mando alterar o status do pino 5 se eu acesso o /LEDCHANGE

Isso está funcionando perfeitamente, mas o problema é outro:

- Estou usando o notebook em um local com sinal wifi fraco, mas totalmente funcional.

- Ao ligar o ESP8266 com esse código ai, o notebook passa a ter o sinal máximo, mas não tem internet, eu só consigo me conectar na página do ESP, o google, facebook ou qualquer outra página fica off.

- Tentando do meu quarto, onde o sinal de internet é melhor, eu consigo me conectar no ESP e na internet.

Alguém saberia explicar o que está acontecendo?

Achei que o ESP não estava localizando a rede, então ele resolveu criar uma nova com o mesmo ID e senha que eu passei, para testar isso, mudei a ID no código e ele não criou uma rede nova com aquela ID, logo, minha hipótese não faz sentido.

Exibições: 171

Anexos

Responder esta

Respostas a este tópico

Bom dia JM,

Os sistemas de transmissão via RF, (o Wifi é RF), geralmente tem circuitos internos para controle do nível de sinal.

São conhecidos como AGC ( Automatic gain control), ele reduzem ou aumentam o ganho do circuito de

recepção dependendo do sinal que chega no antena.

Se você tem um sinal fraco, o AGC tenta ampliar ao máximo, mas ao aparecer um sinal forte, ele reduz o ganho.

Com isto o seu sinal fraco desaparece e por consequência a rede loca fica inacessível.

RV

Entendi.

Mas é normal com o ganho do circuito ele acabar gerando uma rede nova?

Se só bloqueasse a conexão eu entenderia o problema, mas parece que o computador está conectando no ESP, seria como se o esp tivesse se tornado um roteador.

Parte da casa não pegava sinal, agora pega, mas é o ESP que está "roteando" a rede.

Isso é normal? E tem como desativar isso?

Valeu

Muito estranho, esse código não tem nada demais para fazer isso, ele é bem basico, não deveria ser capaz de rotear alguma coisa

Realmente não faz sentido, mas está fazendo isso o tempo todo.

Comprei um NodeMCU e um ESP8266 - 01 (o que tenho agora é o 12), verei se com eles o problema continua.

Valeu.

O ESP não roteia. É uma limitação dele, salvo ter sido vencida.

Para rotear é preciso controlar os dispositivos conectados, manter tabelas, receber e enviar por várias portas, etc. 

Vc está diante de outra coisa. O que é eu não sei.

Mas, de qualquer forma, ninguem merece sinal fraco dentro de sua própria casa.

Recomendo e uso uma solução como essa:

https://www.google.com.br/search?q=Tp-link+Archer+T4uhp+Ac1300&...

Antes tinha apenas wifi a 2.4GHz meia boca no meu quartinho.. Agora tenho a 5GHz direto do modem da vivo.

Essa é uma versão USB. Existem versões roteador também, melhor ainda.

Recomendo algo assim:

https://www.google.com.br/search?q=Roteador+Tplink+Archer+C20+V4+Du...

Tinha antes, na outra casa, uma versão antiga disso, nunca tive esse. Mas deve ser a mesma coisa. Vc pode usar como roteador ou como cliente. como cliente vc conecta tudo de outro espaço da casa na saída dele e ele se conceta ao seu wifi da casa.

No meu quarto o sinal é bom, é ruim em um quarto de bagunça, onde tenho uma bancada para eletrônica, ali nem ligo muito, raramente uso internet lá. No escritório, sala e no meu quarto o sinal é bom.

Em outro quarto a rede nunca chegava (nem mostrava como disponível, era 0 mesmo), agora tem sinal máximo, só que é ao conectar só a página do ESP carrega.

Hoje liguei o ESP antes de ligar o PC no meu quarto de manhã, só consegui me conectar depois de desligar o ESP, ele não está influenciando apenas onde o sinal é fraco, está influenciando todo o local onde o sinal dele chega.

Amanhã ou quinta deve chegar meus novos ESPs, ai verei se o problema está só nessa peça ou o que pode estar acontecendo.

Nesse caso é o que o Rui disse

"

Bom dia JM,

Os sistemas de transmissão via RF, (o Wifi é RF), geralmente tem circuitos internos para controle do nível de sinal.

São conhecidos como AGC ( Automatic gain control), ele reduzem ou aumentam o ganho do circuito de

recepção dependendo do sinal que chega no antena.

Se você tem um sinal fraco, o AGC tenta ampliar ao máximo, mas ao aparecer um sinal forte, ele reduz o ganho.

Com isto o seu sinal fraco desaparece e por consequência a rede loca fica inacessível."

Mas só testando para entender o processo, tenho varias destas placas nunca observei esse comportamento, mas o wifi aqui em casa nos locais que uso tem boa cobertura, deixo o roteador bem elevado (+- na altura da porta) e no centro da casa, assim ele sofre poucas interferências. Tente não deixar o roteador próximo a canto de paredes isso corta muito o sinal.

Pois é, o problema é sim, aparentemente, o que o Rui disse.

A solução é melhorar o sinal...

As vezes trocar a antena (se for removível) por uma maior já ajuda.

Aqui em casa o roteador está preso nas costas da TV, com as antenas fazendo chifrinho nela... Melhor lugar pq minha internet chega perto da tv (vivo fibra) e lá mesmo preciso de sinal a cabo (apple tv, video game, etc). O roteador sobre a cabeça ajuda muito na propagação do sinal. Toda a mobília é eliminada.

Não sei se faz muito sentido melhorar o sinal.

Estou no meu quarto agora, menos de 5 metros do roteador, no windows 10 o sinal fica completo, ou no máximo faltando uma barrinha, ainda assim as vezes a internet para pois se conecta no ESP.

Com o meu celular é a mesma coisa, acabei de pegar ele e achei estranho não ter recebido nada há mais de 2 horas, ele havia se conectado no ESP e ficou sem internet.

Os correios estão piores do que de costume, mas espero que amanhã chegue meus novos ESP e eu possa testar se eles se comportarão da mesma forma.

Obrigado

Boa noite,

Os roteadores WiFi tem limites de conexão.

Eu "chuto" que este limite esteja sendo alcançado quando o ESP se conecta, evitando que o seu notebook consiga se conectar.

Tente desligar algum celular que esteja conectado no mesmo WiFi e nos diga o resultado.

Boa sorte,

  'Eiju

Também não deve ser esse o caso, no roteador constam 6 dispositivos conectados.

Não sei quanto é o limite, mas já tive pelo menos 12 dispositivos conectados sem nenhum problema.

Já testei com o PS4 ligado e com ele desligado (1 dispositivo a menos), não muda nada.

Outro motivo que pode acontecer é:

O seu ESP antigo está recebendo o mesmo IP que o seu notebook.

Alguns servidores DHCP fazem alguns calculos com o MAC Address para definir qual IP será assinalado ao dispositivo.

Não sei se está usando IP fixo no código ou não.

Fica a dica,

  'Eiju

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2018   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço