Boa tarde,

Estou tendo problemas com um lote de ESP07 que comprei no mercado livre e gostaria de uma ajuda.
Fiz uma PCB dedicada com meu circuito onde soldo o ESP07 e carrego o programa com a IDE do Arduino. Pois bem, comprei alguns ESP07 no mercado livre, consigo carregar o sketch neles, porém o ESP não faz nada, não mostra nada no monitor serial. Nem o código do blink funciona.

Tenho outras peças do ESP07 que comprei na China e funcionam normalmente.
Alguém pode me dar uma dica do que pode ser?
Já pesquisei bastante na net e não achei nada.

O módulo com a marca Ai é o que funciona.

Obrigado.

Exibições: 85

As respostas para este tópico estão encerradas.

Respostas a este tópico

Quando carrega os 2 dao exatamente a mesma mensagem ? Digo, quando compila e carrega rola um monte de texto falando que está sendo carregado e tal. Aparece a mesma mensagem ?

Mande fotos...

Existem varios firmwares para os esps. O que carrega codigos arduino é um, tem outros que usam o compilador nativo do esp, outro que aceita comandos AT e outro que programa em Lua... Pode ser a versão.

Não tenho mta experiencia nisso pq os meus sempre funcionaram, embora compre da china e do ML sempre...

Procure um tutorial do tipo firmware upgrade esp8266 ou o seu esp.

Ex:

https://www.instructables.com/id/ESP8266-Firmware-Upgrade/

Boa tarde Eduardo, obrigado pela resposta.
Consegui resolver, mudei o flash mode de DIO para DOUT e deu certo.
Obrigado.

RSS

Destaques

Registre-se no
Lab de Garagem
Clicando aqui

Convide um
amigo para fazer
parte

curso gratis de arduino

© 2019   Criado por Marcelo Rodrigues.   Ativado por

Badges  |  Relatar um incidente  |  Termos de serviço